summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-19 21:58:26 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-19 22:29:01 +0000
commit2f2dedce5bbda66eebe35bdfd298c5600af3e00f (patch)
tree73502250c3eb0579793e264fc8f1d5c1d388cf26 /dev-haskell/warp-tls/warp-tls-3.1.5.ebuild
parentdev-haskell/warp: bump up to 3.1.10 (diff)
downloadgentoo-2f2dedce5bbda66eebe35bdfd298c5600af3e00f.tar.gz
gentoo-2f2dedce5bbda66eebe35bdfd298c5600af3e00f.tar.bz2
gentoo-2f2dedce5bbda66eebe35bdfd298c5600af3e00f.zip
dev-haskell/warp-tls: bump up to 3.1.5
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-haskell/warp-tls/warp-tls-3.1.5.ebuild')
-rw-r--r--dev-haskell/warp-tls/warp-tls-3.1.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/warp-tls/warp-tls-3.1.5.ebuild b/dev-haskell/warp-tls/warp-tls-3.1.5.ebuild
new file mode 100644
index 000000000000..70e5f8a66372
--- /dev/null
+++ b/dev-haskell/warp-tls/warp-tls-3.1.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+#hackport: flags: +tls_1_1_3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="HTTP over TLS support for Warp via the TLS package"
+HOMEPAGE="https://github.com/yesodweb/wai"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cprng-aes-0.5.0:=[profile?]
+ >=dev-haskell/data-default-class-0.0.1:=[profile?]
+ >=dev-haskell/network-2.2.1:=[profile?]
+ dev-haskell/streaming-commons:=[profile?]
+ >=dev-haskell/tls-1.3.2:=[profile?]
+ >=dev-haskell/wai-3.0.4:=[profile?] <dev-haskell/wai-3.1:=[profile?]
+ >=dev-haskell/warp-3.1.7:=[profile?] <dev-haskell/warp-3.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=tls_1_1_3
+}