summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-12 13:46:36 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:15:31 +0000
commit782307d331d7fb64caf9f20495cacdd75d531850 (patch)
tree3b0112d39336703983e2b36dfdd89cabc051476a /dev-haskell/pandoc-lua-marshal/pandoc-lua-marshal-0.1.6.ebuild
parentdev-haskell/optparse-applicative: add 0.16.1.0 (diff)
downloadgentoo-782307d331d7fb64caf9f20495cacdd75d531850.tar.gz
gentoo-782307d331d7fb64caf9f20495cacdd75d531850.tar.bz2
gentoo-782307d331d7fb64caf9f20495cacdd75d531850.zip
dev-haskell/pandoc-lua-marshal: new package, add 0.1.6
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/pandoc-lua-marshal/pandoc-lua-marshal-0.1.6.ebuild')
-rw-r--r--dev-haskell/pandoc-lua-marshal/pandoc-lua-marshal-0.1.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/pandoc-lua-marshal/pandoc-lua-marshal-0.1.6.ebuild b/dev-haskell/pandoc-lua-marshal/pandoc-lua-marshal-0.1.6.ebuild
new file mode 100644
index 000000000000..eb6badb0b986
--- /dev/null
+++ b/dev-haskell/pandoc-lua-marshal/pandoc-lua-marshal-0.1.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Use pandoc types in Lua"
+HOMEPAGE="https://github.com/pandoc/pandoc-lua-marshal"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/hslua-2.1:=[profile?] <dev-haskell/hslua-2.3:=[profile?]
+ >=dev-haskell/hslua-marshalling-2.1:=[profile?] <dev-haskell/hslua-marshalling-2.3:=[profile?]
+ >=dev-haskell/lua-2.1:=[profile?] <dev-haskell/lua-2.3:=[profile?]
+ >=dev-haskell/pandoc-types-1.22.1:=[profile?] <dev-haskell/pandoc-types-1.23:=[profile?]
+ >=dev-haskell/safe-0.3:=[profile?] <dev-haskell/safe-0.4:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+ test? ( >=dev-haskell/quickcheck-2.4 <dev-haskell/quickcheck-2.15
+ >=dev-haskell/tasty-0.11
+ >=dev-haskell/tasty-hunit-0.9
+ >=dev-haskell/tasty-lua-1.0
+ >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.11 )
+"