summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-08-22 09:41:42 +0200
committerJakov Smolić <jsmolic@gentoo.org>2022-08-22 10:02:28 +0200
commitbf4e19b7919e901b2219202c6cf3021563a0beb3 (patch)
tree4e73ddbdbb15ef71ab8bce1ee5709d339cd57716 /dev-haskell/enumerator
parentdev-haskell/equivalence: treeclean (diff)
downloadgentoo-bf4e19b7919e901b2219202c6cf3021563a0beb3.tar.gz
gentoo-bf4e19b7919e901b2219202c6cf3021563a0beb3.tar.bz2
gentoo-bf4e19b7919e901b2219202c6cf3021563a0beb3.zip
dev-haskell/enumerator: treeclean
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-haskell/enumerator')
-rw-r--r--dev-haskell/enumerator/Manifest1
-rw-r--r--dev-haskell/enumerator/enumerator-0.4.20.ebuild30
-rw-r--r--dev-haskell/enumerator/files/enumerator-0.4.20-ghc84.patch21
-rw-r--r--dev-haskell/enumerator/metadata.xml47
4 files changed, 0 insertions, 99 deletions
diff --git a/dev-haskell/enumerator/Manifest b/dev-haskell/enumerator/Manifest
deleted file mode 100644
index 012687f5d414..000000000000
--- a/dev-haskell/enumerator/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST enumerator-0.4.20.tar.gz 53986 BLAKE2B dcb98c31e862194f712c2fe23193557c837d5ba658b89ea50005c2e62d2080d06740793fd4e4629d8dab5000062ef2e3908fea7071ca499e8a2e3f7ca0c1d085 SHA512 90711142b61cee2184420f4d5c9de9563afe6198cccbf5d9d8a75253b307c3df9fee388dc7770e8151f8d7b5570afdb30d8e4e597ce462302dda8430e64050ad
diff --git a/dev-haskell/enumerator/enumerator-0.4.20.ebuild b/dev-haskell/enumerator/enumerator-0.4.20.ebuild
deleted file mode 100644
index c8d35ee60ce3..000000000000
--- a/dev-haskell/enumerator/enumerator-0.4.20.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.3.4.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="Reliable, high-performance processing with left-fold enumerators"
-HOMEPAGE="https://john-millikin.com/software/enumerator/"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-haskell/text-0.7:=[profile?]
- >=dev-haskell/transformers-0.2:=[profile?]
- >=dev-lang/ghc-6.10.4:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6.0.3
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-ghc84.patch
-)
diff --git a/dev-haskell/enumerator/files/enumerator-0.4.20-ghc84.patch b/dev-haskell/enumerator/files/enumerator-0.4.20-ghc84.patch
deleted file mode 100644
index d992228d2e5c..000000000000
--- a/dev-haskell/enumerator/files/enumerator-0.4.20-ghc84.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/enumerator.cabal
-+++ b/enumerator.cabal
-@@ -152,2 +152,5 @@ library
-
-+ if !impl(ghc >= 8.0)
-+ build-depends: semigroups == 0.18.*
-+
- exposed-modules:
---- a/lib/Data/Enumerator/Internal.hs
-+++ b/lib/Data/Enumerator/Internal.hs
-@@ -50,2 +50,3 @@ import Data.Function (fix)
- import Data.Monoid (Monoid, mempty, mappend, mconcat)
-+import qualified Data.Semigroup as S
-
-@@ -73,2 +74,6 @@ instance Monad Stream where
-
-+instance S.Semigroup (Stream a) where
-+ (<>) (Chunks xs) (Chunks ys) = Chunks (xs ++ ys)
-+ (<>) _ _ = EOF
-+
- instance Monoid (Stream a) where
diff --git a/dev-haskell/enumerator/metadata.xml b/dev-haskell/enumerator/metadata.xml
deleted file mode 100644
index 3e0ee48d3525..000000000000
--- a/dev-haskell/enumerator/metadata.xml
+++ /dev/null
@@ -1,47 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- Typical buffer&amp;#x2013;based incremental I/O is based around a single loop,
- which reads data from some source (such as a socket or file), transforms
- it, and generates one or more outputs (such as a line count, HTTP
- responses, or modified file). Although efficient and safe, these loops are
- all single&amp;#x2013;purpose; it is difficult or impossible to compose
- buffer&amp;#x2013;based processing loops.
-
- Haskell&amp;#x2019;s concept of &amp;#x201C;lazy I/O&amp;#x201D; allows pure code to
- operate on data from an external source. However, lazy I/O has several
- shortcomings. Most notably, resources such as memory and file handles can
- be retained for arbitrarily long periods of time, causing unpredictable
- performance and error conditions.
-
- Enumerators are an efficient, predictable, and safe alternative to lazy
- I/O. Discovered by Oleg Kiselyov, they allow large datasets to be processed
- in near&amp;#x2013;constant space by pure code. Although somewhat more complex
- to write, using enumerators instead of lazy I/O produces more correct
- programs.
-
- This library contains an enumerator implementation for Haskell, designed to
- be both simple and efficient. Three core types are defined, along with
- numerous helper functions:
-
- * /Iteratee/: Data sinks, analogous to left folds. Iteratees consume
- a sequence of /input/ values, and generate a single /output/ value.
- Many iteratees are designed to perform side effects (such as printing to
- @stdout@), so they can also be used as monad transformers.
-
- * /Enumerator/: Data sources, which generate input sequences. Typical
- enumerators read from a file handle, socket, random number generator, or
- other external stream. To operate, enumerators are passed an iteratee, and
- provide that iteratee with input until either the iteratee has completed its
- computation, or EOF.
-
- * /Enumeratee/: Data transformers, which operate as both enumerators and
- iteratees. Enumeratees read from an /outer/ enumerator, and provide the
- transformed data to an /inner/ iteratee.
- </longdescription>
-</pkgmetadata>