summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-09 07:43:55 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-10 07:51:42 -0400
commitc4993b6a7a6daa41d9b5b2efb53dc0a0f5e90d64 (patch)
tree3d662f8bc9772125bf58fea765e0a01a8ce7cbb5 /dev-games/t4k-common/t4k-common-0.1.1-r1.ebuild
parentsys-kernel/vanilla-sources: Linux patch 4.19.194 (diff)
downloadgentoo-c4993b6a7a6daa41d9b5b2efb53dc0a0f5e90d64.tar.gz
gentoo-c4993b6a7a6daa41d9b5b2efb53dc0a0f5e90d64.tar.bz2
gentoo-c4993b6a7a6daa41d9b5b2efb53dc0a0f5e90d64.zip
dev-games/t4k-common: svg, text, and build fix
Three patches fix: - tuxmath[svg] crash (bug #763591) - tuxmath lacking text with current libsdl - set_font_size build (bug #759574) Bug: https://bugs.gentoo.org/763591 Closes: https://bugs.gentoo.org/759574 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-games/t4k-common/t4k-common-0.1.1-r1.ebuild')
-rw-r--r--dev-games/t4k-common/t4k-common-0.1.1-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/dev-games/t4k-common/t4k-common-0.1.1-r1.ebuild b/dev-games/t4k-common/t4k-common-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..c395867aa56f
--- /dev/null
+++ b/dev-games/t4k-common/t4k-common-0.1.1-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Library of code shared between tuxmath and tuxtype"
+HOMEPAGE="https://github.com/tux4kids/t4kcommon"
+SRC_URI="https://github.com/tux4kids/t4kcommon/archive/upstream/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/t4kcommon-upstream-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="svg"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-net
+ media-libs/sdl-pango
+ svg? (
+ gnome-base/librsvg:2
+ media-libs/libpng:=
+ x11-libs/cairo
+ )"
+DEPEND="${RDEPEND}"
+# need sys-devel/gettext for AM_ICONV added to configure.ac
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-libpng.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-ICONV_CONST.patch
+ "${FILESDIR}"/${P}-fix-declaration.patch
+ "${FILESDIR}"/${P}-missing-text.patch
+ "${FILESDIR}"/${P}-svg-libxml2.patch
+)
+
+src_prepare() {
+ default
+
+ rm m4/iconv.m4 || die
+ eautoreconf
+}
+
+src_configure() {
+ # note: sdlpango<->sdlttf breaks ABI, prefer default pango
+ local econfargs=(
+ $(usex svg '' --without-rsvg)
+ --disable-static
+ )
+ econf "${econfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}