summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-05-06 01:22:53 -0400
committerSam James <sam@gentoo.org>2024-05-06 07:05:26 +0100
commitfd511cef256c2e34df28fe5e4f3eb09dd1545ba2 (patch)
treeef9188d5ff4149882794f50965e5985f5c23b5ef /dev-games/libnw
parentdev-games/libnw: fix Modern C porting error in vintage configure script (diff)
downloadgentoo-fd511cef256c2e34df28fe5e4f3eb09dd1545ba2.tar.gz
gentoo-fd511cef256c2e34df28fe5e4f3eb09dd1545ba2.tar.bz2
gentoo-fd511cef256c2e34df28fe5e4f3eb09dd1545ba2.zip
dev-games/libnw: remove highly confusing sed to "respect CC"
But it's a generated automake Makefile.in, and the sed is removing every line containing "CC = @CC@", so it's puzzling that anyone ever thought to do this. It was originally added in gentoo-historical-2: 29 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> libnw-1.30.02.ebuild: EAPI=2; respect CC And 15 years later it's the same (2003) tarball and the sed is decidedly not needed (nor ever was). Remove this bloaty junk. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-games/libnw')
-rw-r--r--dev-games/libnw/libnw-1.30.02.ebuild12
1 files changed, 1 insertions, 11 deletions
diff --git a/dev-games/libnw/libnw-1.30.02.ebuild b/dev-games/libnw/libnw-1.30.02.ebuild
index f040c741f587..385052cc6d6e 100644
--- a/dev-games/libnw/libnw-1.30.02.ebuild
+++ b/dev-games/libnw/libnw-1.30.02.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools toolchain-funcs
+inherit autotools
DESCRIPTION="Tools and libraries for NWN file manipulation"
HOMEPAGE="https://sourceforge.net/projects/openknights"
@@ -23,19 +23,9 @@ DOCS=( AUTHORS ChangeLog NEWS README README.tech TODO )
src_prepare() {
default
eautoreconf
-
- local f
- while IFS="" read -d $'\0' -r f; do
- einfo "Removing hardcoded CC/CXX from ${f}"
- sed -i \
- -e '/^CC =/d' \
- -e '/^CXX =/d' \
- "${f}" || die
- done < <(find "${S}" -name Makefile.in -type f -print0)
}
src_configure() {
- tc-export CC CXX
econf --disable-static
}