summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-06 08:45:37 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-11-12 09:51:48 +0200
commit6c2dc5c1486bb04299804a4d923948d983d9f54a (patch)
tree35bd20c6b3d83980c5318a198e22145cddfefc36 /dev-embedded/avra/avra-1.4.2.ebuild
parentdev-embedded/avra: fix CC call (diff)
downloadgentoo-6c2dc5c1486bb04299804a4d923948d983d9f54a.tar.gz
gentoo-6c2dc5c1486bb04299804a4d923948d983d9f54a.tar.bz2
gentoo-6c2dc5c1486bb04299804a4d923948d983d9f54a.zip
dev-embedded/avra: bump to 1.4.2
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-embedded/avra/avra-1.4.2.ebuild')
-rw-r--r--dev-embedded/avra/avra-1.4.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-embedded/avra/avra-1.4.2.ebuild b/dev-embedded/avra/avra-1.4.2.ebuild
new file mode 100644
index 000000000000..0278a2c6bc59
--- /dev/null
+++ b/dev-embedded/avra/avra-1.4.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Atmel AVR Assembler"
+HOMEPAGE="https://github.com/hsoft/avra"
+SRC_URI="https://github.com/hsoft/avra/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ PREFIX=/usr \
+ CFLAGS="${CFLAGS} \$(CDEFS)" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${ED}" install
+ dodoc {AUTHORS,CHANGELOG.md,README.md,USAGE.md}
+}