summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-08-08 17:13:42 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-09 09:02:06 -0400
commitf4b80d4b64def65b73d642d6ce8e1c192e1d52c5 (patch)
treec16e8a3f6fe0d43c4dab9bfe371dead724014e36 /dev-db
parentdev-libs/glib: instrospection support is not meant to be used in multilib (diff)
downloadgentoo-f4b80d4b64def65b73d642d6ce8e1c192e1d52c5.tar.gz
gentoo-f4b80d4b64def65b73d642d6ce8e1c192e1d52c5.tar.bz2
gentoo-f4b80d4b64def65b73d642d6ce8e1c192e1d52c5.zip
dev-db/percona-xtrabackup: drop boost distfile injection
Previous versions of mysql required boost headers to be downloaded. This new version merged the new unique take of mysql: to simply include 115mb worth of boost source code checked into git as a side channel to ensuring it ends up inside the release distfiles. At any rate, downloading our own and passing non-existent options to inject it, is no longer relevant. Closes: https://bugs.gentoo.org/937587 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/percona-xtrabackup/percona-xtrabackup-8.3.0.1.ebuild12
1 files changed, 1 insertions, 11 deletions
diff --git a/dev-db/percona-xtrabackup/percona-xtrabackup-8.3.0.1.ebuild b/dev-db/percona-xtrabackup/percona-xtrabackup-8.3.0.1.ebuild
index e6dd0dc26791..c84d5bb7801d 100644
--- a/dev-db/percona-xtrabackup/percona-xtrabackup-8.3.0.1.ebuild
+++ b/dev-db/percona-xtrabackup/percona-xtrabackup-8.3.0.1.ebuild
@@ -7,8 +7,6 @@ CMAKE_MAKEFILE_GENERATOR="emake"
inherit cmake flag-o-matic
-# TODO: just keep it unbundled...?
-MY_BOOST_VERSION="1.77.0"
MY_PV=$(ver_rs 3 '-')
MY_PV="${MY_PV//_pre*}"
MY_PN="Percona-XtraBackup"
@@ -19,7 +17,7 @@ DESCRIPTION="Hot backup utility for MySQL based servers"
HOMEPAGE="https://www.percona.com/software/mysql-database/percona-xtrabackup"
SRC_URI="
https://downloads.percona.com/downloads/${MY_PN}-innovative-release/${MY_PN}-${MY_PV}/source/tarball/${PN}-${MY_PV}.tar.gz
- https://boostorg.jfrog.io/artifactory/main/release/${MY_BOOST_VERSION}/source/boost_$(ver_rs 1- _ ${MY_BOOST_VERSION}).tar.bz2"
+"
LICENSE="GPL-2"
SLOT="0"
@@ -60,13 +58,6 @@ S="${WORKDIR}/percona-xtrabackup-${MY_PV}"
src_prepare() {
cmake_src_prepare
- local bundled_boost_version=$(sed -En '/^SET\(BOOST_PACKAGE_NAME /{s/[^0-9.]//gp}' cmake/boost.cmake)
- if [[ ${MY_BOOST_VERSION//./} != ${bundled_boost_version} ]] ; then
- eerror "Source Boost version: ${bundled_boost_version}"
- eerror "Ebuild Boost version: ${MY_BOOST_VERSION}"
- die "Ebuild needs to fix MY_BOOST_VERSION!"
- fi
-
local extra
# rapidjson: last released in 2016 and totally unviable to devendor
# lz4: in storage/innobase/xtrabackup/src/CMakeLists.txt it is used even when =system
@@ -89,7 +80,6 @@ src_configure() {
-DBUILD_SHARED_LIBS=OFF
-DCOMPILATION_COMMENT="Gentoo Linux ${PF}"
-DINSTALL_PLUGINDIR=$(get_libdir)/${PN}/plugin
- -DWITH_BOOST="${WORKDIR}/boost_$(ver_rs 1- _ ${MY_BOOST_VERSION})"
-DWITH_MAN_PAGES=ON
-DWITH_SYSTEM_LIBS=ON
# not handled via SYSTEM_LIBS