summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorGabriel Linder <linder.gabriel@gmail.com>2019-12-08 13:53:09 +0100
committerJoonas Niilola <juippis@gentoo.org>2019-12-13 15:48:51 +0200
commit732baefebe38498482daa3015cbed455085e1799 (patch)
tree2baafe383ae3f39f5e8d4c1ce5a468d17b9a4031 /dev-db
parentdev-python/pgspecial: bump to version 1.11.9. (diff)
downloadgentoo-732baefebe38498482daa3015cbed455085e1799.tar.gz
gentoo-732baefebe38498482daa3015cbed455085e1799.tar.bz2
gentoo-732baefebe38498482daa3015cbed455085e1799.zip
dev-db/pgcli: bump to version 2.2.0.
Closes: https://bugs.gentoo.org/696614 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Gabriel Linder <linder.gabriel@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/13918 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pgcli/Manifest1
-rw-r--r--dev-db/pgcli/pgcli-2.2.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-db/pgcli/Manifest b/dev-db/pgcli/Manifest
index 2e35d371fc67..c38c30f56131 100644
--- a/dev-db/pgcli/Manifest
+++ b/dev-db/pgcli/Manifest
@@ -1 +1,2 @@
DIST pgcli-2.0.2.tar.gz 432325 BLAKE2B 5cbe2be05910d9bfa64e7ac908d636a39ed11f994e0e81cd06afce97510e02be335837b2587653df716beee0d30076f07489ac8e4fb05fbc579bceee8636a470 SHA512 5681effcb36101ce408f7c4dcc881984686d63a6e593bd4f5c2bb3b2d870362c787094895ece027a3ba27d3a4524498b27082da0f25b1b77f23e54b2df6c0501
+DIST pgcli-2.2.0.tar.gz 436991 BLAKE2B 9041240952a8ba9a770705850bf4281eaa89ac5b970366c7ec27e705bec65d9c3c455fb2c9d2220d53f4a9ff31142501437faa6974839f6fe59e6fc1618d8a6d SHA512 239a3278b604248b7bd5cdaf4d0b0f3e62188617b04c358d123e2fa2ad1449c3854ef84995b89239fcf559ce010ee0dd80e12ddd72b27dcb89f92ac08d34c49b
diff --git a/dev-db/pgcli/pgcli-2.2.0.ebuild b/dev-db/pgcli/pgcli-2.2.0.ebuild
new file mode 100644
index 000000000000..9dd187a2738f
--- /dev/null
+++ b/dev-db/pgcli/pgcli-2.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="CLI for Postgres with auto-completion and syntax highlighting"
+HOMEPAGE="https://www.pgcli.com https://github.com/dbcli/pgcli"
+SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/prompt_toolkit-2.0.6[${PYTHON_USEDEP}]
+ <dev-python/prompt_toolkit-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/python-sqlparse-0.3.0[${PYTHON_USEDEP}]
+ <dev-python/python-sqlparse-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cli_helpers-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/humanize-0.5.1[${PYTHON_USEDEP}]
+ >=dev-python/pgspecial-1.11.8[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+ >=dev-python/setproctitle-1.1.9[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-db/postgresql
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+# there is a flaky test, so no tests for now
+RESTRICT="test"
+
+distutils_enable_tests pytest