summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-18 08:54:37 +0100
committerSam James <sam@gentoo.org>2023-04-18 08:54:37 +0100
commit3e4e1bd6097ad840d46a72b7772ded571ad09100 (patch)
tree5ca147b831a8dab71828a756b4e3732dba68c2bc /dev-db
parentmedia-tv/mythtv: fix build w/ newer setuptools (diff)
downloadgentoo-3e4e1bd6097ad840d46a72b7772ded571ad09100.tar.gz
gentoo-3e4e1bd6097ad840d46a72b7772ded571ad09100.tar.bz2
gentoo-3e4e1bd6097ad840d46a72b7772ded571ad09100.zip
dev-db/percona-xtrabackup: fix build w/ gcc 13
Closes: https://bugs.gentoo.org/895702 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/percona-xtrabackup/files/percona-xtrabackup-8.0.30.23-gcc13.patch38
-rw-r--r--dev-db/percona-xtrabackup/percona-xtrabackup-8.0.30.23.ebuild3
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-db/percona-xtrabackup/files/percona-xtrabackup-8.0.30.23-gcc13.patch b/dev-db/percona-xtrabackup/files/percona-xtrabackup-8.0.30.23-gcc13.patch
new file mode 100644
index 000000000000..cf13aba845a1
--- /dev/null
+++ b/dev-db/percona-xtrabackup/files/percona-xtrabackup-8.0.30.23-gcc13.patch
@@ -0,0 +1,38 @@
+https://bugs.gentoo.org/895702
+--- a/components/keyrings/common/data/data.h
++++ b/components/keyrings/common/data/data.h
+@@ -23,6 +23,7 @@
+ #ifndef DATA_INCLUDED
+ #define DATA_INCLUDED
+
++#include <cstdint>
+ #include <functional>
+ #include <string>
+ #include "pfs_string.h"
+--- a/libbinlogevents/include/gtids/global.h
++++ b/libbinlogevents/include/gtids/global.h
+@@ -23,6 +23,7 @@
+ #ifndef CS_GTIDS_GLOBALS_INCLUDED
+ #define CS_GTIDS_GLOBALS_INCLUDED
+
++#include <cstdint>
+ #include <set>
+ #include <sstream>
+ #include "libbinlogevents/include/uuid.h"
+@@ -34,4 +35,4 @@ typedef binary_log::Uuid Uuid;
+
+ } // namespace binary_log::gtids
+
+-#endif
+\ No newline at end of file
++#endif
+--- a/sql/dd/impl/sdi.h
++++ b/sql/dd/impl/sdi.h
+@@ -23,6 +23,7 @@
+ #ifndef DD__SDI_INCLUDED
+ #define DD__SDI_INCLUDED
+
++#include <cstdint>
+ #include <functional>
+ #include "my_compiler.h"
+ #include "sql/dd/sdi_fwd.h" // RJ_Document
diff --git a/dev-db/percona-xtrabackup/percona-xtrabackup-8.0.30.23.ebuild b/dev-db/percona-xtrabackup/percona-xtrabackup-8.0.30.23.ebuild
index d0a696311550..7c1066f1f22d 100644
--- a/dev-db/percona-xtrabackup/percona-xtrabackup-8.0.30.23.ebuild
+++ b/dev-db/percona-xtrabackup/percona-xtrabackup-8.0.30.23.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -50,6 +50,7 @@ RDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-8.0.26-remove-rpm.patch
+ "${FILESDIR}"/${PN}-8.0.30.23-gcc13.patch
)
S="${WORKDIR}/percona-xtrabackup-${MY_PV}"