summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-06 23:41:47 +0000
committerSam James <sam@gentoo.org>2022-01-10 23:05:02 +0000
commitcbbc4230812e3d7484284a9fcd4ef9c01a833df3 (patch)
tree1b7eb4d155feda2ad1a4685187a4f096b4490745 /dev-cpp/pangomm
parentdev-cpp/pangomm: turn off maintainer-mode (diff)
downloadgentoo-cbbc4230812e3d7484284a9fcd4ef9c01a833df3.tar.gz
gentoo-cbbc4230812e3d7484284a9fcd4ef9c01a833df3.tar.bz2
gentoo-cbbc4230812e3d7484284a9fcd4ef9c01a833df3.zip
dev-cpp/pangomm: add 2.46.2
Will resolve confusing conflicts with gtkmm/pangomm too. Bug: https://bugs.gentoo.org/830881 Closes: https://bugs.gentoo.org/829510 Closes: https://github.com/gentoo/gentoo/pull/23680 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/pangomm')
-rw-r--r--dev-cpp/pangomm/Manifest1
-rw-r--r--dev-cpp/pangomm/pangomm-2.46.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-cpp/pangomm/Manifest b/dev-cpp/pangomm/Manifest
index 77711bcf8458..06c798d3e1b3 100644
--- a/dev-cpp/pangomm/Manifest
+++ b/dev-cpp/pangomm/Manifest
@@ -1,3 +1,4 @@
DIST pangomm-2.42.2.tar.xz 656760 BLAKE2B 8fae779aa78b2337b83759adc7aadec1f61c08c54d892e3cdd05180e2ab032a61faa72c39281fab649bcd08591c5d7ace9ea65b25f76ce17d6f4d96f38900b6a SHA512 5e4826d64c0178527b4df73e901d2fdf5661d41777e189f5e2d4b26577e42689efaccf5a28502246c6b3926571ccd5876cb23d33267b44ace7ee164322c14667
+DIST pangomm-2.46.2.tar.xz 674892 BLAKE2B ac86ef1a229dca29eeb41d3751128bed56d182cecfc6655a478b5a7473d10782fe98cdfee4db6f5afbfe9fb8adbf0e646004aa69c4c4058191078c7b5716434b SHA512 79cad137ec9f22e57a177332df6c6e735aa3baf81df36fc706e81e7a89f23ce3179337507388f65a0d0a74733990dc3547c50243a4559dfd0bb065b1828c0474
DIST pangomm-2.48.1.tar.xz 675452 BLAKE2B bb012fc5cb66d5cb98f522e3706fdd35bcc5692fcd942f86ee1e20116590ceca26874c5a58bd3f8fac4f154700dfb37ea060747a6c3069e67adf83ba551e7abc SHA512 c204a1cb7a404f055d62880a760716c5567a835ca495cc5e01589ed59fabb332490e529de716c3438cefbc4428c025d6d01c71e4412b2843e3ab3a3175ccc2f4
DIST pangomm-2.50.0.tar.xz 753592 BLAKE2B 0db7d43fe2d23e4cfc2b083a4d832c7875c63a261c6b10c62898bf428351ea7d8d05136a46f9498cdb78c51a0223ca988cbc3481041b997dc5d6a9f16f02ec91 SHA512 844850db93b8c4dab19dd364e674ee3d61b2fcb8e020ab3d314f240065ee17aeceea21e9ddc438a7d09d56410e3f82147a57425f76bb01e26d82872934269477
diff --git a/dev-cpp/pangomm/pangomm-2.46.2.ebuild b/dev-cpp/pangomm/pangomm-2.46.2.ebuild
new file mode 100644
index 000000000000..9bb444efdde0
--- /dev/null
+++ b/dev-cpp/pangomm/pangomm-2.46.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit gnome.org meson-multilib python-any-r1
+
+DESCRIPTION="C++ interface for pango"
+HOMEPAGE="https://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+"
+SLOT="1.4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="doc"
+
+DEPEND="
+ >=dev-cpp/cairomm-1.2.2:0[doc?,${MULTILIB_USEDEP}]
+ >=dev-cpp/glibmm-2.48.0:2[doc?,${MULTILIB_USEDEP}]
+ dev-libs/libsigc++:2[doc?,${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.45.1[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen[dot]
+ dev-lang/perl
+ dev-libs/libxslt
+ )
+ ${PYTHON_DEPS}
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dmaintainer-mode=false
+ $(meson_native_use_bool doc build-documentation)
+ )
+ meson_src_configure
+}