summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-02-26 17:21:50 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-02-26 17:22:45 +0100
commit78332276fb6993d830c1c869970f66726969921b (patch)
treea9d9a7070b424948bf780b6004f667ad47a0bb05 /dev-ada
parentsci-chemistry/dssp: drop 4.0.4 (diff)
downloadgentoo-78332276fb6993d830c1c869970f66726969921b.tar.gz
gentoo-78332276fb6993d830c1c869970f66726969921b.tar.bz2
gentoo-78332276fb6993d830c1c869970f66726969921b.zip
dev-ada/libadalang: py3.11, gcc_12 & EAPI 8
Closes: https://bugs.gentoo.org/896668 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/libadalang/files/libadalang-23.0.0-test.patch11
-rw-r--r--dev-ada/libadalang/libadalang-23.0.0-r1.ebuild (renamed from dev-ada/libadalang/libadalang-23.0.0.ebuild)8
2 files changed, 16 insertions, 3 deletions
diff --git a/dev-ada/libadalang/files/libadalang-23.0.0-test.patch b/dev-ada/libadalang/files/libadalang-23.0.0-test.patch
new file mode 100644
index 000000000000..ac5738d5a685
--- /dev/null
+++ b/dev-ada/libadalang/files/libadalang-23.0.0-test.patch
@@ -0,0 +1,11 @@
+--- a/user_manual/changes/V325-006.yaml 2022-09-15 14:51:28.000000000 +0200
++++ b/user_manual/changes/V325-006.yaml 2023-02-26 16:41:25.121927720 +0100
+@@ -1,7 +1,7 @@
+ type: bugfix
+ title: Fix exponentiation in Ada integer literal decoding
+ description: |
+- Libadalang’s decoder for integer literals (the
++ Libadalang's decoder for integer literals (the
+ ``Libadalang.Sources.Decode_Integer_Literal`` procedure) applied the exponent
+ in base 10 regardless of the base of the literal being evaluated. This is
+ wrong, as the ARM (2.4.2) states:
diff --git a/dev-ada/libadalang/libadalang-23.0.0.ebuild b/dev-ada/libadalang/libadalang-23.0.0-r1.ebuild
index 7ebaec865511..6df305d7916c 100644
--- a/dev-ada/libadalang/libadalang-23.0.0.ebuild
+++ b/dev-ada/libadalang/libadalang-23.0.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_10 )
-ADA_COMPAT=( gnat_2021 gcc_12_2_0 )
+PYTHON_COMPAT=( python3_{10..11} )
+ADA_COMPAT=( gnat_2021 gcc_12 gcc_12_2_0 )
inherit ada python-single-r1 multiprocessing
@@ -43,6 +43,8 @@ BDEPEND="test? (
<dev-lang/ocaml-4.14
)"
+PATCHES=( "${FILESDIR}"/${P}-test.patch )
+
pkg_setup() {
python-single-r1_pkg_setup
ada_pkg_setup