summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-03-12 16:10:30 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-09-14 23:22:30 +0200
commit417c436dd1c56ce5b4dbda17591a04d27d5c5382 (patch)
treef88b3ed752b2d9193f560e0eaf56cc4b7616d42e /app-vim/bnf-syntax
parentapp-vim/alternate: EAPI8 bump (diff)
downloadgentoo-417c436dd1c56ce5b4dbda17591a04d27d5c5382.tar.gz
gentoo-417c436dd1c56ce5b4dbda17591a04d27d5c5382.tar.bz2
gentoo-417c436dd1c56ce5b4dbda17591a04d27d5c5382.zip
app-vim/bnf-syntax: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-vim/bnf-syntax')
-rw-r--r--app-vim/bnf-syntax/bnf-syntax-1.2-r3.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-vim/bnf-syntax/bnf-syntax-1.2-r3.ebuild b/app-vim/bnf-syntax/bnf-syntax-1.2-r3.ebuild
new file mode 100644
index 000000000000..8e08807acb05
--- /dev/null
+++ b/app-vim/bnf-syntax/bnf-syntax-1.2-r3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: BNF file syntax highlighting"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=250"
+
+LICENSE="vim.org"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting for BNF files."
+
+src_prepare() {
+ default
+ # fix hi link to use def, bug #101790.
+ sed -i -e 's,hi link,hi def link,g' syntax/bnf.vim || die "sed failed"
+}