summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-15 13:12:54 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-15 13:13:57 +0100
commitd9c2621a064d648831f399092467b42b184b4b8e (patch)
treeff6f24793bb4ae1173daa524c234047696fe2750 /app-text
parentsys-apps/gawk: drop broken 5.2.0 (diff)
downloadgentoo-d9c2621a064d648831f399092467b42b184b4b8e.tar.gz
gentoo-d9c2621a064d648831f399092467b42b184b4b8e.tar.bz2
gentoo-d9c2621a064d648831f399092467b42b184b4b8e.zip
app-text/zotero-bin: add 6.0.18
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/zotero-bin/Manifest2
-rw-r--r--app-text/zotero-bin/zotero-bin-6.0.18.ebuild87
2 files changed, 89 insertions, 0 deletions
diff --git a/app-text/zotero-bin/Manifest b/app-text/zotero-bin/Manifest
index 17048a993a5b..9736488e3e04 100644
--- a/app-text/zotero-bin/Manifest
+++ b/app-text/zotero-bin/Manifest
@@ -1,2 +1,4 @@
DIST zotero-bin-6.0.16-amd64.tar.bz2 69199096 BLAKE2B 3b97576a930df2eca06b052b23c60871772ec94b9a42fd257e3b20aba3fd90aa96db656f174a9544fad737481bd5a1fca36db804207acdd7971fda67b72f9802 SHA512 e79c052ab8d94cc53cdf1fa3e0852a3984b3305768e8363f515440b20a6f0390781a16e14dc753a71493313df6f3c626832aa1a4ced9d4305a8a54a233ac4a2d
DIST zotero-bin-6.0.16-x86.tar.bz2 70892888 BLAKE2B a2ad3f880960af100863c60da3066d5223f6e2336cefcba9ed0bf0088f15f72155bfb11b4ea0e3b7017cc77d26999d8d16d5264c310e8241fdbbccbacd6153c0 SHA512 434f447d3f754d7e7b02617b02673d0fe565a5c642537bc16ca634ed2f747fd60fe025d2e448cd63644bf671443685bf998223df5cbe875cf56d1b0f48740412
+DIST zotero-bin-6.0.18-amd64.tar.bz2 69200236 BLAKE2B c1dc30b1c295652866068742051c5e42f686a4073fb1501d8d4e0eac2945d65205d92f65f2d2626ad279a7c1f073e22bb58b72ff5bd48497158de5587e753896 SHA512 c839ab2f34f946d2f58c544ca915b9e7386f115aa6a68ea95e0b7293e234140bb64118eac7640cbfa09592879b398db8c8be97da3cee3bab58e8ecbbbe09f9e1
+DIST zotero-bin-6.0.18-x86.tar.bz2 70892698 BLAKE2B 49f23ef1d2a682bb945bf4b43c52e05551414597e6d16b89cefcd07588d158d917c63a7014d23969b5590caf2c79bc8875d03e9e6b2d709ce168acd8420435b6 SHA512 d7c70336a66c208f636ea4c96fde3b1e6547b7f1422a328f24f1ab2e2f25fce21d0ab69a98c787d9ffaa6f70e02995231365c07bf8da0f145adec875d008aa84
diff --git a/app-text/zotero-bin/zotero-bin-6.0.18.ebuild b/app-text/zotero-bin/zotero-bin-6.0.18.ebuild
new file mode 100644
index 000000000000..8f643569fc34
--- /dev/null
+++ b/app-text/zotero-bin/zotero-bin-6.0.18.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="Helps you collect, organize, cite, and share your research sources"
+HOMEPAGE="https://www.zotero.org"
+SRC_URI="
+ amd64? ( https://www.zotero.org/download/client/dl?channel=release&platform=linux-x86_64&version=${PV} -> ${P}-amd64.tar.bz2 )
+ x86? ( https://www.zotero.org/download/client/dl?channel=release&platform=linux-i686&version=${PV} -> ${P}-x86.tar.bz2 )
+"
+S="${WORKDIR}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="
+ app-accessibility/at-spi2-core
+ dev-libs/dbus-glib
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/zotero/*"
+
+src_prepare() {
+ if use amd64; then
+ cd Zotero_linux-x86_64 || die
+ elif use x86; then
+ cd Zotero_linux-i686 || die
+ fi
+
+ # disable auto-update
+ sed -i -e 's/\(pref("app.update.enabled"\).*/\1, false);/' defaults/preferences/prefs.js || die
+
+ # disable default oo installation questions - manual installation is still possible
+ sed -i -e 's/\(pref("extensions.zoteroOpenOfficeIntegration.skipInstallation"\).*/\1, true);/' \
+ extensions/zoteroOpenOfficeIntegration@zotero.org/defaults/preferences/zoteroOpenOfficeIntegration.js || die
+
+ # fix desktop-file
+ sed -i -e 's#^Exec=.*#Exec=zotero#' zotero.desktop || die
+ sed -i -e 's#Icon=zotero.*#Icon=zotero#' zotero.desktop || die
+
+ default
+}
+
+src_install() {
+ if use amd64; then
+ cd Zotero_linux-x86_64 || die
+ elif use x86; then
+ cd Zotero_linux-i686 || die
+ fi
+
+ dodir opt/zotero
+ cp -a * "${ED}/opt/zotero" || die
+
+ dosym ../../opt/zotero/zotero usr/bin/zotero
+
+ domenu zotero.desktop
+
+ for size in 16 32 48 256; do
+ newicon -s ${size} chrome/icons/default/default${size}.png zotero.png
+ done
+}