summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-08-16 19:17:07 -0400
committerMichael Orlitzky <mjo@gentoo.org>2023-08-16 22:17:08 -0400
commitb0dc96aaa6d93e29fd4076143d988db4e0f1f0ed (patch)
tree736cec4c38f3a221383796d4f181b87c2d370999 /app-text
parentmate-base/mate-common: add 1.27.0 (diff)
downloadgentoo-b0dc96aaa6d93e29fd4076143d988db4e0f1f0ed.tar.gz
gentoo-b0dc96aaa6d93e29fd4076143d988db4e0f1f0ed.tar.bz2
gentoo-b0dc96aaa6d93e29fd4076143d988db4e0f1f0ed.zip
app-text/atril: add 1.27.0
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/atril/Manifest1
-rw-r--r--app-text/atril/atril-1.27.0.ebuild120
2 files changed, 121 insertions, 0 deletions
diff --git a/app-text/atril/Manifest b/app-text/atril/Manifest
index a48462402025..238d84dab9f9 100644
--- a/app-text/atril/Manifest
+++ b/app-text/atril/Manifest
@@ -1,2 +1,3 @@
DIST atril-1.26.0.tar.xz 1986160 BLAKE2B 40de33749113144c49341cf8249bd20de37c3d64f3daa865dfe2bcad117e1c2b5aae2aef3b4e0199fd2656b17af236e2a863ef97933decc5072e3419219154e4 SHA512 9c4e8b1c45959136c8fc4c5db47117e45e8afca8be2294418e6c1a0f8098c162ccaa4a60e5baea34db91d45d345a3953afe95281782986e7046b87a34c8f7dbd
DIST atril-1.26.1.tar.xz 2087068 BLAKE2B d655bffb4a8245bb3cc25fc91d08ba64ade22fb6da24f5fcb9c418c020c99df66c85a0b59f1d0c31a2f450650d9807adc248a7baeb74cb696bf3687270572f47 SHA512 276e80a81234f3228065f3a804fbd8a306ac948978f3dfd233f678dc4fb6f833ebd1123950996ae08869fac112ebb0d2785ab60fde6bfddd2d2c407a2c991ea3
+DIST atril-1.27.0.tar.xz 2082372 BLAKE2B 4f8a3002e9979474be71a7b8d5fda1fc63bc9f3b231dfed7db9a66b0e23acf7d7fd24de070ca55974b19ec4a54d2d95542b84b150ade632087b9e638c6faa404 SHA512 1e8bdf689517be073943b49a81244138d3ebb7783cc45ccc1847eb545ba2897d63a01a5a87b95b359b23760f7f843131ac3f7e2912b0320d9dd5d0f765bfe843
diff --git a/app-text/atril/atril-1.27.0.ebuild b/app-text/atril/atril-1.27.0.ebuild
new file mode 100644
index 000000000000..7f2d928a2dd0
--- /dev/null
+++ b/app-text/atril/atril-1.27.0.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MATE_LA_PUNT="yes"
+
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit mate python-any-r1 virtualx
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="Atril document viewer for MATE"
+LICENSE="FDL-1.1+ GPL-2+ GPL-3+ LGPL-2+ LGPL-2.1+"
+SLOT="0"
+
+IUSE="caja dbus debug djvu dvi epub +introspection keyring nls +postscript synctex t1lib test tiff xps"
+
+REQUIRED_USE="t1lib? ( dvi )"
+
+COMMON_DEPEND="
+ app-accessibility/at-spi2-core:2
+ app-text/poppler[cairo]
+ dev-libs/glib:2
+ dev-libs/libxml2:2
+ sys-libs/zlib
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3[introspection?]
+ x11-libs/libICE
+ x11-libs/libSM:0
+ x11-libs/libX11
+ x11-libs/cairo
+ x11-libs/pango
+ caja? ( mate-base/caja[introspection?] )
+ djvu? ( app-text/djvu:0 )
+ dvi? (
+ virtual/tex-base
+ t1lib? ( media-libs/t1lib:5 )
+ )
+ epub? (
+ <dev-libs/mathjax-3
+ net-libs/webkit-gtk:4.1
+ )
+ keyring? ( app-crypt/libsecret )
+ introspection? ( dev-libs/gobject-introspection:= )
+ postscript? ( app-text/libspectre )
+ synctex? ( virtual/tex-base )
+ tiff? ( media-libs/tiff:= )
+ xps? ( app-text/libgxps )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+BDEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]') )
+"
+
+#RESTRICT="!test? ( test )"
+# Tests use dogtail and require using accessibility services.
+# Until we figure out how to run successfully, don't run tests
+RESTRICT="test"
+
+PATCHES=(
+ # https://github.com/mate-desktop/atril/issues/582
+ "${FILESDIR}/${PN}-1.26.1-webkitgtk4.1.patch"
+)
+
+python_check_deps() {
+ use test && python_has_version "dev-util/dogtail[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ # Passing --disable-help would drop offline help, that would be inconsistent
+ # with helps of the most of GNOME apps that doesn't require network for that.
+ mate_src_configure \
+ --enable-comics \
+ --enable-pdf \
+ --enable-pixbuf \
+ --enable-previewer \
+ --enable-thumbnailer \
+ $(use_with keyring) \
+ $(use_enable caja) \
+ $(use_enable dbus) \
+ $(use_enable debug) \
+ $(use_enable djvu) \
+ $(use_enable dvi) \
+ $(use_enable epub) \
+ $(use_enable introspection) \
+ $(use_enable nls) \
+ $(use_enable postscript ps) \
+ $(use_enable synctex) \
+ $(use_enable t1lib) \
+ $(use_enable test tests) \
+ $(use_enable tiff) \
+ $(use_enable xps)
+}
+
+src_test() {
+ export GSETTINGS_BACKEND=keyfile
+ gsettings set org.gnome.desktop.interface toolkit-accessibility true || die
+ gsettings set org.mate.interface accessibility true || die
+ virtx emake check
+}