summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-08 16:36:52 +0000
committerSam James <sam@gentoo.org>2024-03-08 16:36:52 +0000
commit798c9e417802ba6a4cf40cb5ebfcd7586345321a (patch)
treef19bbbaa802fb7c870c7e892fc589a57291c89ea /app-text
parentdev-libs/xapian: add 1.4.25 (diff)
downloadgentoo-798c9e417802ba6a4cf40cb5ebfcd7586345321a.tar.gz
gentoo-798c9e417802ba6a4cf40cb5ebfcd7586345321a.tar.bz2
gentoo-798c9e417802ba6a4cf40cb5ebfcd7586345321a.zip
app-text/xapian-omega: add 1.4.25
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/xapian-omega/Manifest1
-rw-r--r--app-text/xapian-omega/xapian-omega-1.4.25.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-text/xapian-omega/Manifest b/app-text/xapian-omega/Manifest
index 33ef87f86267..9baffa3dacb6 100644
--- a/app-text/xapian-omega/Manifest
+++ b/app-text/xapian-omega/Manifest
@@ -1,3 +1,4 @@
DIST xapian-omega-1.4.22.tar.xz 570476 BLAKE2B 05bd5c8135870b3a2058bcd032da9609cac7d0b1a07b31cb84f8fdf175bb87d22acd9beb392f93ebf1f23e4ebf4d23fbe12b70063628d318012b71246d14f26b SHA512 460120fa2c76ad99f818f4183c4ded92eaa7f01a9dd782af1e93faf11caf2479053f45a9e9f0a602bf31631dba8be2d2c18bba28340c578126e8658ad4937c19
DIST xapian-omega-1.4.23.tar.xz 571596 BLAKE2B fee64cf73a7bc8e6951c3555f1139bec8c94102b00ccf3a0a69c5037002f122f0d1688a798967f997f85d6c21bd69d72758168408d95159a7442bc46050fe915 SHA512 2137972cebb10315f35024c8a5e179ce082eab777e4fd795ba6700eeab0d77ec49b6e06d104222e77824898c25c1717d346564d59e5f349360fec89476e3ee4f
DIST xapian-omega-1.4.24.tar.xz 580736 BLAKE2B bdefb4a28185e5966c8f7ec7056562bdca39d02b5fb92d57b3b4ab051107fb80d198c5f2d460d067fa085ebad99276476b6ec0cb53636ae4dd3fb62f6a546f0e SHA512 d3a5c5c4de9a13ed2e55ab46915aaea1ba51120b5716a4e7cab9fb628ef2c979c83e17a44d3354045459d08a6d7041322182d9c81bdbb54eb6bd53431d147a9c
+DIST xapian-omega-1.4.25.tar.xz 578904 BLAKE2B d0bb62741f7c58d1398a4dc8bca3de2b385094fb8126a4e36f424cb09964ac350709bf6dabc38d8d7ebf5f3fcd213d2a444d8e5e5cc52c6353f1c72fc7eebd72 SHA512 2b0d855baaaabbf6da1b86d61f0d3e85d5fb62d1b7d04738a7e15758d0042b9e22f80f0aa273b9a9a21b04dff579c561280e44f2a69a0c0d4f270cb0fbcef169
diff --git a/app-text/xapian-omega/xapian-omega-1.4.25.ebuild b/app-text/xapian-omega/xapian-omega-1.4.25.ebuild
new file mode 100644
index 000000000000..1e0983f89c26
--- /dev/null
+++ b/app-text/xapian-omega/xapian-omega-1.4.25.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="An application built on Xapian, consisting of indexers and a CGI search frontend"
+HOMEPAGE="https://xapian.org/"
+SRC_URI="https://oligarchy.co.uk/xapian/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ dev-lang/perl
+ dev-libs/libpcre2:=
+ ~dev-libs/xapian-${PV}:0/30
+ sys-apps/file
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}" install
+
+ # Protect /etc/omega.conf
+ echo "CONFIG_PROTECT=\"/etc/omega.conf\"" > "${T}"/20xapian-omega || die
+ doenvd "${T}"/20xapian-omega
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+
+ # Directory containing Xapian databases:
+ keepdir /var/lib/omega/data
+
+ # Directory containing OmegaScript templates:
+ keepdir /var/lib/omega/templates
+ mv "${S}"/templates/* "${ED}"/var/lib/omega/templates || die
+
+ # Directory to write Omega logs to:
+ keepdir /var/log/omega
+
+ # Directory containing any cdb files for the $lookup OmegaScript command:
+ keepdir /var/lib/omega/cdb
+}