summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicu Borta <nicu.borta111@gmail.com>2024-04-06 15:09:12 +0300
committerJoonas Niilola <juippis@gentoo.org>2024-05-31 16:40:40 +0300
commit15c83a66d3ba6174ff72cbb2d53580686ef2a9ac (patch)
treec66977ce09700765498fa26a2a4e2c8a5ae9cdaf /app-text
parentnet-p2p/nicotine+: add python 3.12 support (diff)
downloadgentoo-15c83a66d3ba6174ff72cbb2d53580686ef2a9ac.tar.gz
gentoo-15c83a66d3ba6174ff72cbb2d53580686ef2a9ac.tar.bz2
gentoo-15c83a66d3ba6174ff72cbb2d53580686ef2a9ac.zip
app-text/zathura: fix 9999 ebuild
Update disable-seccomp-tests patch. Bump girara version. Make sqlite a hard dependency. Signed-off-by: Nicu Borta <nicu.borta111@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36137 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/zathura/files/zathura-9999-disable-seccomp-tests.patch22
-rw-r--r--app-text/zathura/zathura-9999.ebuild9
2 files changed, 26 insertions, 5 deletions
diff --git a/app-text/zathura/files/zathura-9999-disable-seccomp-tests.patch b/app-text/zathura/files/zathura-9999-disable-seccomp-tests.patch
new file mode 100644
index 000000000000..09947eb722b4
--- /dev/null
+++ b/app-text/zathura/files/zathura-9999-disable-seccomp-tests.patch
@@ -0,0 +1,22 @@
+diff --git a/tests/meson.build b/tests/meson.build
+index 10531a5..1c79e29 100644
+--- a/tests/meson.build
++++ b/tests/meson.build
+@@ -54,17 +54,5 @@ if check.found()
+ args: xvfb_args + [session],
+ timeout: 60*60
+ )
+-
+- if seccomp.found()
+- sandbox = executable('test_sandbox', ['test_sandbox.c', 'tests.c'],
+- dependencies: build_dependencies + test_dependencies,
+- include_directories: include_directories,
+- c_args: defines + flags
+- )
+- test('sandbox', xvfb,
+- args: xvfb_args + [sandbox],
+- timeout: 60*60
+- )
+- endif
+ endif
+ endif
diff --git a/app-text/zathura/zathura-9999.ebuild b/app-text/zathura/zathura-9999.ebuild
index 3cf03fc8f6e7..0a26c971eaf0 100644
--- a/app-text/zathura/zathura-9999.ebuild
+++ b/app-text/zathura/zathura-9999.ebuild
@@ -22,19 +22,19 @@ fi
LICENSE="ZLIB"
SLOT="0/5.6"
-IUSE="seccomp sqlite synctex test"
+IUSE="seccomp synctex test"
RESTRICT="!test? ( test )"
RDEPEND="
- >=dev-libs/girara-0.4.1
+ >=dev-libs/girara-0.4.3
>=dev-libs/glib-2.50:2
dev-libs/json-glib
sys-apps/file
x11-libs/cairo
>=x11-libs/gtk+-3.22:3
+ >=dev-db/sqlite-3.6.23:3
seccomp? ( sys-libs/libseccomp )
- sqlite? ( >=dev-db/sqlite-3.6.23:3 )
synctex? ( app-text/texlive-core )
"
DEPEND="
@@ -50,7 +50,7 @@ BDEPEND="
"
PATCHES=(
- "${FILESDIR}/zathura-0.5.4-disable-seccomp-tests.patch"
+ "${FILESDIR}"/${P}-disable-seccomp-tests.patch
)
src_configure() {
@@ -58,7 +58,6 @@ src_configure() {
-Dconvert-icon=disabled
-Dmanpages=disabled
-Dseccomp=$(usex seccomp enabled disabled)
- -Dsqlite=$(usex sqlite enabled disabled)
-Dsynctex=$(usex synctex enabled disabled)
)
meson_src_configure