summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-04-01 14:49:12 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-14 18:55:45 +0300
commit1143a532982140a22df88bdfc5d3adde40394686 (patch)
treef98441165f26fefd4701dca906050c5b1736a1b7 /app-text
parentapp-shells/tmux-bash-completion: EAPI=8 (diff)
downloadgentoo-1143a532982140a22df88bdfc5d3adde40394686.tar.gz
gentoo-1143a532982140a22df88bdfc5d3adde40394686.tar.bz2
gentoo-1143a532982140a22df88bdfc5d3adde40394686.zip
app-text/cedilla: EAPI8 bump, fix LICENSE
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/cedilla/cedilla-0.7-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-text/cedilla/cedilla-0.7-r1.ebuild b/app-text/cedilla/cedilla-0.7-r1.ebuild
new file mode 100644
index 000000000000..ba9a1e203dc8
--- /dev/null
+++ b/app-text/cedilla/cedilla-0.7-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="UTF-8 to postscript converter"
+HOMEPAGE="http://www.pps.jussieu.fr/~jch/software/cedilla/
+ https://github.com/jech/cedilla"
+SRC_URI="http://www.pps.jussieu.fr/~jch/software/files/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-lisp/clisp"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/cedilla-gentoo-r1.patch )
+
+src_compile() {
+ ./compile-cedilla || die "Compile failed."
+}
+
+src_install() {
+ sed "s#${ED}##g" -i cedilla || die "sed failed"
+ dodir /usr/share/man/man1/
+
+ ./install-cedilla || die "Install failed."
+
+ einstalldocs
+}