summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2022-03-28 01:20:12 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2022-03-28 01:20:12 +0200
commit54759854a6a79e63768eeccb1e4b100e07e5c001 (patch)
treea1cd3fbe39e869549d093d3a6d486a0715ee5ddf /app-text/zathura
parentdev-libs/girara: 0.3.7 version bump; takeover. (diff)
downloadgentoo-54759854a6a79e63768eeccb1e4b100e07e5c001.tar.gz
gentoo-54759854a6a79e63768eeccb1e4b100e07e5c001.tar.bz2
gentoo-54759854a6a79e63768eeccb1e4b100e07e5c001.zip
app-text/zathura: 0.4.9 version bump.
Closes: https://bugs.gentoo.org/836127 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'app-text/zathura')
-rw-r--r--app-text/zathura/Manifest1
-rw-r--r--app-text/zathura/zathura-0.4.9.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-text/zathura/Manifest b/app-text/zathura/Manifest
index ae606ede97b0..3a6a59ca1536 100644
--- a/app-text/zathura/Manifest
+++ b/app-text/zathura/Manifest
@@ -1,2 +1,3 @@
DIST zathura-0.4.7.tar.gz 199857 BLAKE2B c4fd99049ed81c7965cc474f0c543ebd1aef55ff63312c21a33ce9161afb78da1c9f0a13ff86d5d69b2ce6b17965632de282a9c8bd60b0a8297d96528b5f2c5f SHA512 adfe69cbef6088a6fa7d49686194a0a3dc13757535974476742c733076dc5bb5ad95ed447d50cd1efdfb23fe2fb1f64452d5d8aeb27a80c3101f2ab5c68f9b60
DIST zathura-0.4.8.tar.gz 202264 BLAKE2B 70916ac23624b8e55b39bc2b9329fc5d992d3e2e3989b17bebf0f8b1bcb26ed943c15866c0b37e0a4a29fee7c264d6309bf1d036d770817e13a14a13af7499d7 SHA512 00d7b735154ff0e857f8a0a21c24b3fbbff8c166d93a34bee725072ee00f2870adecb956e9445334be2a84827778bd874cc1d4bda7f8b32e4468ea3784834b86
+DIST zathura-0.4.9.tar.gz 206194 BLAKE2B 0dd4b153cf7f8e3ddd4ede5514389b2c5e4aa88e2c416646acc38f7e19419e11165c2a5b51548a05d69a1b947e661b885f7c9d8c100179d0d23d8754cb441d97 SHA512 fbab65cba7ac37e4021233a4ae0356a85f4a88d2c1a2d8337cd627eae389856b6b4e692904233332d2fa14ad0300e8c52732059a75314a0ef147a02ca9f8db10
diff --git a/app-text/zathura/zathura-0.4.9.ebuild b/app-text/zathura/zathura-0.4.9.ebuild
new file mode 100644
index 000000000000..c368be85b53a
--- /dev/null
+++ b/app-text/zathura/zathura-0.4.9.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson virtualx xdg
+
+DESCRIPTION="A highly customizable and functional document viewer"
+HOMEPAGE="https://pwmt.org/projects/zathura/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
+ EGIT_BRANCH="develop"
+else
+ SRC_URI="https://github.com/pwmt/zathura/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="ZLIB"
+SLOT="0"
+IUSE="doc +magic seccomp sqlite synctex test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND=">=dev-libs/girara-0.3.7
+ >=dev-libs/glib-2.50:2
+ >=sys-devel/gettext-0.19.8
+ x11-libs/cairo
+ >=x11-libs/gtk+-3.22:3
+ magic? ( sys-apps/file )
+ seccomp? ( sys-libs/libseccomp )
+ sqlite? ( >=dev-db/sqlite-3.5.9:3 )
+ synctex? ( app-text/texlive-core )"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="doc? ( dev-python/sphinx )
+ test? ( dev-libs/appstream-glib
+ dev-libs/check )
+ virtual/pkgconfig"
+
+src_configure() {
+ local emesonargs=(
+ -Dconvert-icon=disabled
+ -Dmagic=$(usex magic enabled disabled)
+ -Dmanpages=$(usex doc enabled disabled)
+ -Dseccomp=$(usex seccomp enabled disabled)
+ -Dsqlite=$(usex sqlite enabled disabled)
+ -Dsynctex=$(usex synctex enabled disabled)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}