summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-05 22:32:32 +0000
committerSam James <sam@gentoo.org>2021-04-05 22:33:26 +0000
commitd68f550bb71767b4cadd452a36698f7e1f0a6b15 (patch)
tree9a7a68e988937921d0c166f6651452e492d1a25f /app-text/xmlto
parentnet-dialup/mgetty: drop old version (diff)
downloadgentoo-d68f550bb71767b4cadd452a36698f7e1f0a6b15.tar.gz
gentoo-d68f550bb71767b4cadd452a36698f7e1f0a6b15.tar.bz2
gentoo-d68f550bb71767b4cadd452a36698f7e1f0a6b15.zip
app-text/xmlto: allow elinks
There's been a lot of history about allowing elinks but ours in Gentoo is an active fork, so let's give it a whirl. It's already listed in the deps anyway. Thanks-to: dolphinling Closes: https://bugs.gentoo.org/679626 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/xmlto')
-rw-r--r--app-text/xmlto/files/xmlto-0.0.28-allow-links.patch15
-rw-r--r--app-text/xmlto/xmlto-0.0.28-r5.ebuild (renamed from app-text/xmlto/xmlto-0.0.28-r4.ebuild)11
2 files changed, 24 insertions, 2 deletions
diff --git a/app-text/xmlto/files/xmlto-0.0.28-allow-links.patch b/app-text/xmlto/files/xmlto-0.0.28-allow-links.patch
new file mode 100644
index 000000000000..abb583fc9044
--- /dev/null
+++ b/app-text/xmlto/files/xmlto-0.0.28-allow-links.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/679626
+Thanks-to: dolphinling
+--- a/configure.in
++++ b/configure.in
+@@ -100,8 +100,8 @@ dnl
+ AC_ARG_VAR([LYNX], [Name and path of the `lynx' browser.])
+ AC_PATH_PROG([LYNX], [lynx], [lynx])
+
+-AC_ARG_VAR([LINKS], [Name and path of the `elinks' browser.])
+-AC_PATH_PROG([LINKS], [elinks], [elinks])
++AC_ARG_VAR([LINKS], [Name and path of the `links/elinks' browser.])
++AC_PATH_PROG([LINKS], [links elinks], [links])
+
+ AC_ARG_VAR([W3M], [Name and path of the `w3m' browser.])
+ AC_PATH_PROG([W3M], [w3m], [w3m])
diff --git a/app-text/xmlto/xmlto-0.0.28-r4.ebuild b/app-text/xmlto/xmlto-0.0.28-r5.ebuild
index 02c6d5f1d33d..9188b524d598 100644
--- a/app-text/xmlto/xmlto-0.0.28-r4.ebuild
+++ b/app-text/xmlto/xmlto-0.0.28-r5.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit autotools
+
DESCRIPTION="Script for converting XML and DocBook documents to a variety of output formats"
HOMEPAGE="https://pagure.io/xmlto"
SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.bz2"
@@ -12,12 +14,14 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="latex text"
-RDEPEND="app-text/docbook-xsl-stylesheets
+RDEPEND="
+ app-text/docbook-xsl-stylesheets
app-text/docbook-xml-dtd:4.2
dev-libs/libxslt
|| ( sys-apps/util-linux app-misc/getopt )
text? ( || ( virtual/w3m www-client/elinks www-client/links www-client/lynx ) )
- latex? ( dev-texlive/texlive-formatsextra )"
+ latex? ( dev-texlive/texlive-formatsextra )
+"
# We only depend on flex when we patch the input lexer.
DEPEND="${RDEPEND}"
@@ -25,6 +29,7 @@ DOCS=( AUTHORS ChangeLog FAQ NEWS README THANKS )
PATCHES=(
"${FILESDIR}"/${PN}-0.0.22-format_fo_passivetex_check.patch
+ "${FILESDIR}"/${PN}-0.0.28-allow-links.patch
)
src_prepare() {
@@ -34,6 +39,8 @@ src_prepare() {
if [[ ${CHOST} == *-solaris* ]] ; then
sed -i -e 's/\(attrib\|val\)/XMLTO\1/g' xmlif/xmlif.l || die
fi
+
+ eautoreconf
}
src_configure() {