summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/u2ps
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/u2ps')
-rw-r--r--app-text/u2ps/Manifest1
-rw-r--r--app-text/u2ps/metadata.xml13
-rw-r--r--app-text/u2ps/u2ps-0.8.4.ebuild44
3 files changed, 58 insertions, 0 deletions
diff --git a/app-text/u2ps/Manifest b/app-text/u2ps/Manifest
new file mode 100644
index 000000000000..07b88be7eb4c
--- /dev/null
+++ b/app-text/u2ps/Manifest
@@ -0,0 +1 @@
+DIST u2ps-full-0.8.4.tar.gz 5496922 SHA256 accf30cdce12fc722edc51a86c7dc4afdc34a34a7a10260805e4bcdbdfab0880 SHA512 31e5c22163a934a3e153ec95e2e5dd94ce79f71a72278a386a6446b1dd053161c896344c51b696c37d838eb3f06fa6fe1db6b5daa55812a06467b2525266363e WHIRLPOOL a91cb69252de557d97c6c7dec91359e391ee2282140fcd05fe817ac47a25bc8126681fbce27f79270bb81b0be572ba4d2bea5cca83e10908652eeba11f11433e
diff --git a/app-text/u2ps/metadata.xml b/app-text/u2ps/metadata.xml
new file mode 100644
index 000000000000..5c07908ce9d2
--- /dev/null
+++ b/app-text/u2ps/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">u2ps.berlios</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/u2ps/u2ps-0.8.4.ebuild b/app-text/u2ps/u2ps-0.8.4.ebuild
new file mode 100644
index 000000000000..f104670819df
--- /dev/null
+++ b/app-text/u2ps/u2ps-0.8.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A text to PostScript converter like a2ps, but supports UTF-8"
+HOMEPAGE="http://sourceforge.net/projects/u2ps.berlios/"
+SRC_URI="mirror://sourceforge/project/${PN}.berlios/${PN}-full-${PV}.tar.gz"
+
+LICENSE="GPL-3 GPL-3-with-font-exception free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-lang/perl-5.6
+ dev-perl/Text-CharWidth
+ app-text/ghostscript-gpl
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}-full-${PV}
+
+src_configure() {
+ ./configure \
+ --prefix=/usr \
+ --datadir=/usr/share \
+ --mandir=/usr/share/man \
+ --with-perl=/usr/bin/perl \
+ --with-gs=/usr/bin/gs \
+ || die 'configure failed'
+}
+
+src_compile() {
+ emake
+ emake man
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc README DESIGN
+ doman man/u2ps.1
+}