summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2023-08-27 18:57:44 +0200
committerSebastian Pipping <sping@gentoo.org>2023-08-27 18:59:19 +0200
commit0dcb48362055b3e92b8c4a6c66321326f933daeb (patch)
tree4330be6ac2a83e599389f1af22e50ca8f5b4c70c /app-text/nuspell
parentapp-emulation/vagrant: add 2.3.7 (diff)
downloadgentoo-0dcb48362055b3e92b8c4a6c66321326f933daeb.tar.gz
gentoo-0dcb48362055b3e92b8c4a6c66321326f933daeb.tar.bz2
gentoo-0dcb48362055b3e92b8c4a6c66321326f933daeb.zip
app-text/nuspell: 5.1.3 + EAPI 8
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'app-text/nuspell')
-rw-r--r--app-text/nuspell/Manifest1
-rw-r--r--app-text/nuspell/nuspell-5.1.3.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-text/nuspell/Manifest b/app-text/nuspell/Manifest
index ea55bfbdbb8b..abbf75798c18 100644
--- a/app-text/nuspell/Manifest
+++ b/app-text/nuspell/Manifest
@@ -1 +1,2 @@
DIST nuspell-5.1.2.tar.gz 371092 BLAKE2B 720ff398ae34ff92884f4eec97e90d88082562a73046a7189f9fa0e93c3ca9de08033e06e27eae6e22ff027428dc904ea4d1e7870aacdaea45712ea2db1755c5 SHA512 138212ae5340836f0bc85d9d5327dc43ffdb1481ca72678b4619938b86c4c8e7c156eec1446f459636460a9015cd476031ad53d0979325e637ed97c19e2f87c8
+DIST nuspell-5.1.3.tar.gz 371496 BLAKE2B 7a4aa05b01bd085e0612cf681783cfa2314a3b775c283f7e25c19d6afbb5af74c7ea2ffe149c68ca422383c24bd043e4b5e6b0895a0acd7c376e3d39f253a867 SHA512 72c868f734848be79c7cfb0502298626307213e4f3f422f8e9ee7dac24cb3d79ea55d04ef0443e7107bb11eb545c79a15a8aea8cb056dc2805c23bd5e3292562
diff --git a/app-text/nuspell/nuspell-5.1.3.ebuild b/app-text/nuspell/nuspell-5.1.3.ebuild
new file mode 100644
index 000000000000..c90ea9e71d03
--- /dev/null
+++ b/app-text/nuspell/nuspell-5.1.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Spell checker library and CLI for complex natural languages"
+HOMEPAGE="https://nuspell.github.io/ https://github.com/nuspell/nuspell"
+SRC_URI="https://github.com/nuspell/nuspell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0/5" # due to libnuspell.so.5
+KEYWORDS="~amd64 ~loong ~riscv ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-libs/icu-60"
+DEPEND="${RDEPEND}
+ doc? ( virtual/pandoc )
+ test? ( <dev-cpp/catch-3:0 )
+ "
+
+DOCS=( CHANGELOG.md )
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ if ! use test ; then
+ rm -R external/hunspell/ || die
+ fi
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ einfo
+ einfo 'Nuspell needs language packs and/or dictionaries to be of use'
+ einfo 'e.g. package app-dicts/myspell-en or one of its siblings.'
+ einfo
+ einfo 'Besides MySpell dictionaries, for other options please'
+ einfo 'see https://nuspell.github.io/#languages-and-users .'
+ einfo
+}