summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJouni Kosonen <jouni.kosonen@tukesoft.com>2020-07-24 15:05:30 +0300
committerSam James <sam@gentoo.org>2020-09-02 21:53:35 +0000
commit0c66b1512801731efb3c03fd9a6e79895a22aecc (patch)
tree0f47e007aa38728bbe701ce50b7de5cb3bcb0e24 /app-text/llpp
parentsys-apps/ethtool: fix crash in do_sset() (diff)
downloadgentoo-0c66b1512801731efb3c03fd9a6e79895a22aecc.tar.gz
gentoo-0c66b1512801731efb3c03fd9a6e79895a22aecc.tar.bz2
gentoo-0c66b1512801731efb3c03fd9a6e79895a22aecc.zip
app-text/llpp: version bump to 31
v31 works with mupdf-1.16.1 and ocaml-4.09.0 currently in the tree Bug: https://bugs.gentoo.org/733332 Signed-off-by: Jouni Kosonen <jouni.kosonen@tukesoft.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/llpp')
-rw-r--r--app-text/llpp/Manifest1
-rw-r--r--app-text/llpp/llpp-31.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-text/llpp/Manifest b/app-text/llpp/Manifest
index 5a5f1b30293c..bbcec5684f14 100644
--- a/app-text/llpp/Manifest
+++ b/app-text/llpp/Manifest
@@ -1,2 +1,3 @@
DIST llpp-30.tar.gz 165821 BLAKE2B 755648f9f7e0e0740dd9647559c085ab1626edfceb91d8df4aa783610f32499d744f24a2e0ac0d6f13e747695e8829112e59bcf0fc78c7ef5f4b2427c759353d SHA512 1dfcf273bdabfb3c7b38366bac60659555b943f459cb3fd6e656df1a33c0f84e6745d62522c5498df0bd6182bda13973144724054588c07145018bb3e758d893
DIST llpp-30_p20190316.tar.gz 169517 BLAKE2B 56dbb4fc1f46e654f15986edf870bec22c3d26c694915db88125d99b8f0460c70ac3bd48c82f45f32939f5a09753a4ec6f2e6d544397a0d6ba242640c363917d SHA512 c736b94595eab1fd45e6fb6aa89a988e0c3ec1f4c7c88f8655d17a88c9ff62c6b7db4396a3934690861b5e61af595baa6736b92c585ad68c51677f3e577bd713
+DIST llpp-31.tar.gz 169199 BLAKE2B 3f60db741fb94bf1b4753f5443705e68f062a68212fd3d0d8062f54b3b71002dc0ee3ba3040f9be028a40d8e96de11c8c53966196e631458f65d863f90f7226f SHA512 d9e213078899ece4a92291199bc2ea962c40a185b9908a7db241a773f57c64e08b004a8433984b86cc4b59088f97991b2ee8ee94e75d71536ce378dd32316e57
diff --git a/app-text/llpp/llpp-31.ebuild b/app-text/llpp/llpp-31.ebuild
new file mode 100644
index 000000000000..78104778ab62
--- /dev/null
+++ b/app-text/llpp/llpp-31.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs xdg-utils
+
+DESCRIPTION="Graphical PDF viewer which aims to superficially resemble less(1)"
+HOMEPAGE="https://github.com/moosotc/llpp"
+SRC_URI="https://github.com/moosotc/llpp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+ocamlopt static-libs"
+
+RDEPEND="=app-text/mupdf-1.16*:0=[static-libs?]
+ app-arch/bzip2[static-libs?]
+ media-libs/fontconfig:1.0[static-libs?]
+ media-libs/freetype:2[static-libs?]
+ media-libs/jbig2dec:=[static-libs?]
+ media-libs/openjpeg:2[static-libs?]
+ sys-libs/zlib[static-libs?]
+ virtual/jpeg:0[static-libs?]
+ x11-libs/libX11[static-libs?]
+ x11-libs/libXau[static-libs?]
+ x11-libs/libXdmcp[static-libs?]
+ x11-misc/xsel"
+DEPEND="${RDEPEND}
+ dev-ml/lablgl[glut,ocamlopt?]"
+BDEPEND="
+ >=dev-lang/ocaml-4.09[ocamlopt?]
+ app-text/asciidoc
+ virtual/pkgconfig"
+
+RESTRICT="!ocamlopt? ( strip )"
+
+PATCHES=( "${FILESDIR}"/${PN}-30-keysym.patch )
+
+src_prepare() {
+ default
+
+ # use custom makefile from archlinux with minor changes
+ cp "${FILESDIR}"/Makefile "${S}" || die
+
+ # re-add desktop file removed upstream
+ cp "${FILESDIR}"/llpp.desktop "${S}"/misc || die
+
+ # remove empty interface definition
+ rm "${S}"/main.mli || die
+}
+
+src_compile() {
+ emake -j1 VERSION=${PV} CC="$(tc-getCC)" LIBDIR="/usr/$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+ dodoc README Thanks
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}