summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-15 13:18:04 +0100
committerSam James <sam@gentoo.org>2023-10-15 13:18:41 +0100
commite87ea692351c280f2d47aa6d5d11e657691d6a40 (patch)
tree67d2f13805b38fcb7d425ad7bfd7635c5a1e65a0 /app-text/libspectre
parentdev-util/desktop-file-utils: add 0.27 (diff)
downloadgentoo-e87ea692351c280f2d47aa6d5d11e657691d6a40.tar.gz
gentoo-e87ea692351c280f2d47aa6d5d11e657691d6a40.tar.bz2
gentoo-e87ea692351c280f2d47aa6d5d11e657691d6a40.zip
app-text/libspectre: add 0.2.12
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/libspectre')
-rw-r--r--app-text/libspectre/Manifest1
-rw-r--r--app-text/libspectre/libspectre-0.2.12.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-text/libspectre/Manifest b/app-text/libspectre/Manifest
index 83a532983584..6311d5b76c16 100644
--- a/app-text/libspectre/Manifest
+++ b/app-text/libspectre/Manifest
@@ -1 +1,2 @@
DIST libspectre-0.2.11.tar.gz 435887 BLAKE2B 46e289553dafe520c76a779ce64f8f5e320541221d885e5707284dd6d89ace7985a0a658fcf26c5ea750fd2751dd2bab0913333cda563ab5ee29c4132f8c99a5 SHA512 97335bc927006031fad8be55befae44bec33347f058f5b1fcf828a8a8d45a6fae2d51ceae4aaffcfa563c7592fdffe1e5a4993f145d6832ec81019c00ae0e37f
+DIST libspectre-0.2.12.tar.gz 436264 BLAKE2B 932f934e4ef66c4319d60ea88842d01caf3663262f6b67606dfc5750eba7d9e13a1e3e0b15764215e703ff1542c3c09387ee4f572075e828ae2f3680d002821c SHA512 3a4045c1e94e7de23b437393389397dd2448363458023b5aa8e43fa0553a160216f038e157374cefc1d09fa74711ad4899aac1fc353c482bd5fe970d9a97461f
diff --git a/app-text/libspectre/libspectre-0.2.12.ebuild b/app-text/libspectre/libspectre-0.2.12.ebuild
new file mode 100644
index 000000000000..b7dec6b75172
--- /dev/null
+++ b/app-text/libspectre/libspectre-0.2.12.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Library for rendering Postscript documents"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libspectre"
+SRC_URI="https://libspectre.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="debug doc"
+
+RDEPEND=">=app-text/ghostscript-gpl-9.53.0:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[doc] )
+"
+
+# does not actually test anything, see bug 362557
+RESTRICT="test"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug asserts)
+ $(use_enable debug checks)
+ --disable-test
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ doxygen || die
+ fi
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}