summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-07-01 19:23:25 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-07-01 19:23:25 +0200
commitb5a6aa1975cdadb431bc36d59367ac0d8ee27553 (patch)
treeb9a9ffcb0b5992346e70643e048b69e6f5e20737 /app-text/kramdown-rfc
parentdev-java/coursier-bin: drop 2.1.0 (diff)
downloadgentoo-b5a6aa1975cdadb431bc36d59367ac0d8ee27553.tar.gz
gentoo-b5a6aa1975cdadb431bc36d59367ac0d8ee27553.tar.bz2
gentoo-b5a6aa1975cdadb431bc36d59367ac0d8ee27553.zip
app-text/kramdown-rfc: add 1.6.36
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-text/kramdown-rfc')
-rw-r--r--app-text/kramdown-rfc/Manifest1
-rw-r--r--app-text/kramdown-rfc/kramdown-rfc-1.6.36.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-text/kramdown-rfc/Manifest b/app-text/kramdown-rfc/Manifest
index da84e7b968f8..9145c93d620a 100644
--- a/app-text/kramdown-rfc/Manifest
+++ b/app-text/kramdown-rfc/Manifest
@@ -1,2 +1,3 @@
DIST kramdown-rfc2629-1.6.27.gem 57344 BLAKE2B e43d46a02e804268ebf5697fde7948c1c1e90f2cb33f0aa66c93c629e6f68f7932ecf02cd7169c93d06f21ee77e9c98b2717c6c18629fc78d2532098ef4e4f5f SHA512 7ad473bf9221f8369afaa6374751d77931f12e7af3500576da7567cc4e36844349de412626e735432dea098d71d155cb1fd1d87f9e3ea053bebd3be84da81c17
DIST kramdown-rfc2629-1.6.35.gem 60928 BLAKE2B 91438fb8d58f59da8d69f7065478ae66e80a9a5958c5e87ab4c342e1abf0f3ee38c411b05d9e8d24d1f06093426a9db4552fda4914907ec7bd4dfd45668e9e71 SHA512 88d24c5c8a236733422dc3b863376c9007d4ea5e68977f4ebc5dcff51782995ab169c790d5a89fa4ae53966e92d1142fe5bf3135cd56e02eeecf0abd2290b098
+DIST kramdown-rfc2629-1.6.36.gem 60928 BLAKE2B e1f5a3299ddca462b7ab3935019b95f58aebfc5de52271142b41cbf03102a574181b0d29d5701e0f6b710eb7c8b85dda0f9700b8e47698b6d079cd8c07d720b0 SHA512 d3c32bd0e692ebf5dfb428617ce6ae37ac91ff99021a59e11df205e88c76699c8fabd8dd7922f6e9a5653b12e3c113eeedbb38b6edd656d67cd16b5f03a3136e
diff --git a/app-text/kramdown-rfc/kramdown-rfc-1.6.36.ebuild b/app-text/kramdown-rfc/kramdown-rfc-1.6.36.ebuild
new file mode 100644
index 000000000000..ff1033582610
--- /dev/null
+++ b/app-text/kramdown-rfc/kramdown-rfc-1.6.36.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31"
+
+# The software got renamed from kramdown-rfc2629 to kramdown-rfc,
+# however the gem coordinate is still kramdown-rfc2629.
+RUBY_FAKEGEM_NAME="${PN}2629"
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+# Explicitly use the gemspec file over the metadata file of the gem, as
+# the latter contains dependencies that we patched out.
+RUBY_FAKEGEM_GEMSPEC="${RUBY_FAKEGEM_NAME}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An XML2RFC (RFC799x) backend for Thomas Leitner's kramdown markdown parser"
+HOMEPAGE="https://github.com/cabo/kramdown-rfc"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.27-Drop-dependency-on-certified.patch
+ "${FILESDIR}"/${PN}-1.6.35-Remove-bin-echars.patch
+)
+
+ruby_add_rdepend "
+ >=dev-ruby/json-2.0.0
+ >=dev-ruby/kramdown-2.4.0
+ >=dev-ruby/kramdown-parser-gfm-1.1.0
+ >=dev-ruby/net-http-persistent-4.0
+"
+
+all_ruby_prepare() {
+ sed -i 's/json_pure/json/' "${RUBY_FAKEGEM_GEMSPEC}" || die
+}