summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-10 00:29:28 +0000
committerSam James <sam@gentoo.org>2021-03-10 00:29:28 +0000
commit0e4ca75c33d0fe6bbe74324cfe09520894393c15 (patch)
treee47a86906beabf14ad7f8341a904213a69f5ddd6 /app-text/groonga
parentapp-text/groonga: replace invalid use of EROOT (diff)
downloadgentoo-0e4ca75c33d0fe6bbe74324cfe09520894393c15.tar.gz
gentoo-0e4ca75c33d0fe6bbe74324cfe09520894393c15.tar.bz2
gentoo-0e4ca75c33d0fe6bbe74324cfe09520894393c15.zip
app-text/groonga: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/groonga')
-rw-r--r--app-text/groonga/groonga-8.0.2.ebuild25
1 files changed, 18 insertions, 7 deletions
diff --git a/app-text/groonga/groonga-8.0.2.ebuild b/app-text/groonga/groonga-8.0.2.ebuild
index 81552b275bfc..19c48773526c 100644
--- a/app-text/groonga/groonga-8.0.2.ebuild
+++ b/app-text/groonga/groonga-8.0.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit libtool user
@@ -26,11 +26,17 @@ RDEPEND=">=dev-libs/onigmo-6.1.1:0=
zeromq? ( net-libs/zeromq:0= )
zlib? ( sys-libs/zlib:0= )
zstd? ( app-arch/zstd:0= )"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
- sphinx? ( dev-python/sphinx )"
+ sphinx? ( dev-python/sphinx )
+"
-REQUIRED_USE=" abort? ( dynamic-malloc-change ) fmalloc? ( dynamic-malloc-change ) sphinx? ( doc )"
+REQUIRED_USE="
+ abort? ( dynamic-malloc-change )
+ fmalloc? ( dynamic-malloc-change )
+ sphinx? ( doc )
+"
pkg_setup() {
enewgroup groonga
@@ -38,7 +44,8 @@ pkg_setup() {
}
src_prepare() {
- default_src_prepare
+ default
+
elibtoolize
}
@@ -80,14 +87,16 @@ src_configure() {
$(use_with zlib)
$(use_with zstd)
)
+
econf "${econfopts[@]}"
}
src_install() {
local DOCS=( README.md )
+
default
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
newinitd "${FILESDIR}/${PN}.initd" ${PN}
newconfd "${FILESDIR}/${PN}.confd" ${PN}
@@ -95,5 +104,7 @@ src_install() {
keepdir /var/{log,lib}/${PN}
fowners groonga:groonga /var/{log,lib}/${PN}
- use examples || rm -r "${D%/}/usr/share/${PN}" || die
+ if ! use examples ; then
+ rm -r "${ED}/usr/share/${PN}" || die
+ fi
}