summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/blahtexml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/blahtexml')
-rw-r--r--app-text/blahtexml/Manifest1
-rw-r--r--app-text/blahtexml/blahtexml-0.9.ebuild40
-rw-r--r--app-text/blahtexml/files/blahtexml-0.9-Makefile.patch55
-rw-r--r--app-text/blahtexml/files/blahtexml-0.9-gcc-4.7.patch24
-rw-r--r--app-text/blahtexml/files/blahtexml.190
-rw-r--r--app-text/blahtexml/metadata.xml8
6 files changed, 218 insertions, 0 deletions
diff --git a/app-text/blahtexml/Manifest b/app-text/blahtexml/Manifest
new file mode 100644
index 000000000000..c4624da77536
--- /dev/null
+++ b/app-text/blahtexml/Manifest
@@ -0,0 +1 @@
+DIST blahtexml-0.9-src.tar.gz 168564 SHA256 c5145b02bdf03cd95b7b136de63286819e696639824961d7408bec4591bc3737 SHA512 5a5ddd50c0b3a25954135c44de0ac3a3d992e3e9dd691a552512415c385a39011595683877cdf98aee77d6ef2f9dae750214798ec2af69b8de089d0aec64b042 WHIRLPOOL 10aed077f16914f2ceff02929069c305a1b6a154e0aafea1c25048b9394c2fddb76cd852c83a1025464e89ecaf7d68d0f552e47818696a0343518fea8deb2852
diff --git a/app-text/blahtexml/blahtexml-0.9.ebuild b/app-text/blahtexml/blahtexml-0.9.ebuild
new file mode 100644
index 000000000000..451353f65328
--- /dev/null
+++ b/app-text/blahtexml/blahtexml-0.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="TeX-to-MathML converter"
+HOMEPAGE="http://gva.noekeon.org/blahtexml"
+SRC_URI="http://gva.noekeon.org/${PN}/${P}-src.tar.gz"
+
+LICENSE="BSD CC-BY-3.0 ZLIB"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/xerces-c"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-text/texlive-core
+ dev-libs/libxslt
+ dev-tex/latex2html )"
+
+src_prepare() {
+ tc-export CC CXX
+ epatch "${FILESDIR}"/${P}-{Makefile,gcc-4.7}.patch
+}
+
+src_compile() {
+ emake blahtex{,ml}-linux
+ use doc && emake doc
+}
+
+src_install() {
+ dobin blahtex ${PN}
+ doman "${FILESDIR}"/${PN}.1
+ use doc && dodoc Documentation/manual.pdf
+}
diff --git a/app-text/blahtexml/files/blahtexml-0.9-Makefile.patch b/app-text/blahtexml/files/blahtexml-0.9-Makefile.patch
new file mode 100644
index 000000000000..f5f01eac71aa
--- /dev/null
+++ b/app-text/blahtexml/files/blahtexml-0.9-Makefile.patch
@@ -0,0 +1,55 @@
+Use pkg-config for xerces-c
+Respect CXX and CC
+Replace CFLAGS with CXXFLAGS where needed
+Add LDFLAGS
+
+--- a/makefile
++++ b/makefile
+@@ -93,35 +93,40 @@
+
+ $(BINDIR_XMLIN)/InputSymbolTranslation.o: InputSymbolTranslation.cpp InputSymbolTranslation.inc
+
+-CFLAGS = -O2
++PKG_CONFIG ?= pkg-config
++CFLAGS ?= -O2
+
+ VPATH = Source:Source/BlahtexCore:Source/BlahtexXMLin
+
+ INCLUDES=-I. -ISource -ISource/BlahtexCore -ISource/BlahtexXMLin
+
++CXXFLAGS += $(shell $(PKG_CONFIG) --cflags xerces-c)
++
++XERCES_LIB = $(shell $(PKG_CONFIG) --libs xerces-c)
++
+ $(BINDIR)/%.o:%.cpp
+- $(CXX) $(INCLUDES) $(CFLAGS) -c $< -o $@
++ $(CXX) $(INCLUDES) $(CXXFLAGS) -c $< -o $@
+
+ $(BINDIR)/%.o:%.c
+ $(CC) $(INCLUDES) $(CFLAGS) -c $< -o $@
+
+ $(BINDIR_XMLIN)/%.o:%.cpp
+- $(CXX) $(INCLUDES) $(CFLAGS) -DBLAHTEXML_USING_XERCES -c $< -o $@
++ $(CXX) $(INCLUDES) $(CXXFLAGS) -DBLAHTEXML_USING_XERCES -c $< -o $@
+
+ $(BINDIR_XMLIN)/%.o:%.c
+ $(CC) $(INCLUDES) $(CFLAGS) -DBLAHTEXML_USING_XERCES -c $< -o $@
+
+ blahtex-linux: $(BINDIR) $(OBJECTS) $(HEADERS)
+- $(CXX) $(CFLAGS) -o blahtex $(OBJECTS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o blahtex $(OBJECTS) $(LIBS)
+
+ blahtex-mac: $(BINDIR) $(OBJECTS) $(HEADERS)
+- $(CXX) $(CFLAGS) -o blahtex -liconv $(OBJECTS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o blahtex -liconv $(OBJECTS) $(LIBS)
+
+ blahtexml-linux: $(BINDIR_XMLIN) $(OBJECTS_XMLIN) $(HEADERS_XMLIN)
+- $(CXX) $(CFLAGS) -o blahtexml $(OBJECTS_XMLIN) -lxerces-c
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o blahtexml $(OBJECTS_XMLIN) $(LIBS) $(XERCES_LIB)
+
+ blahtexml-mac: $(BINDIR_XMLIN) $(OBJECTS_XMLIN) $(HEADERS_XMLIN)
+- $(CXX) $(CFLAGS) -o blahtexml -liconv $(OBJECTS_XMLIN) -lxerces-c
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o blahtexml -liconv $(OBJECTS_XMLIN) $(LIBS) $(XERCES_LIB)
+
+ clean:
+ rm -f blahtex $(OBJECTS) blahtexml $(OBJECTS_XMLIN)
diff --git a/app-text/blahtexml/files/blahtexml-0.9-gcc-4.7.patch b/app-text/blahtexml/files/blahtexml-0.9-gcc-4.7.patch
new file mode 100644
index 000000000000..c570e1de679b
--- /dev/null
+++ b/app-text/blahtexml/files/blahtexml-0.9-gcc-4.7.patch
@@ -0,0 +1,24 @@
+Description: Fix FTBFS with gcc 4.7 by fixing missing <unistd.h> includes.
+Author: Cyril Brulebois <kibi@debian.org>
+Bug-Debian: http://bugs.debian.org/667116
+
+--- blahtexml-0.9.orig/Source/main.cpp
++++ blahtexml-0.9/Source/main.cpp
+@@ -24,6 +24,7 @@ THIS SOFTWARE IS PROVIDED BY THE COPYRIG
+ #include <stdlib.h>
+ #include <sstream>
+ #include <stdexcept>
++#include <unistd.h>
+
+ using namespace std;
+ using namespace blahtex;
+--- blahtexml-0.9.orig/Source/mainPng.cpp
++++ blahtexml-0.9/Source/mainPng.cpp
+@@ -27,6 +27,7 @@ THIS SOFTWARE IS PROVIDED BY THE COPYRIG
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <sstream>
++#include <unistd.h>
+
+
+ using namespace std;
diff --git a/app-text/blahtexml/files/blahtexml.1 b/app-text/blahtexml/files/blahtexml.1
new file mode 100644
index 000000000000..a82c8491a770
--- /dev/null
+++ b/app-text/blahtexml/files/blahtexml.1
@@ -0,0 +1,90 @@
+.\" Hey, EMACS: -*- nroff -*-
+.\" First parameter, NAME, should be all caps
+.\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
+.\" other parameters are allowed: see man(7), man(1)
+.TH BLAHTEXML 1 "March 17, 2010"
+.\" Please adjust this date whenever revising the manpage.
+.\"
+.\" Some roff macros, for reference:
+.\" .nh disable hyphenation
+.\" .hy enable hyphenation
+.\" .ad l left justify
+.\" .ad b justify to both left and right margins
+.\" .nf disable filling
+.\" .fi enable filling
+.\" .br insert line break
+.\" .sp <n> insert n+1 empty lines
+.\" for manpage-specific macros, see man(7)
+.SH NAME
+blahtexml \- Converts TeX equations into MathML
+.SH SYNOPSIS
+.B blahtexml
+.RI [ options ] " files" ...
+.SH DESCRIPTION
+This manual page documents briefly the
+.B blahtexml
+command.
+.PP
+.\" TeX users may be more comfortable with the \fB<whatever>\fP and
+.\" \fI<whatever>\fP escape sequences to invode bold face and italics,
+.\" respectively.
+\fBblahtexml\fP converts an equation given in a syntax close to TeX into
+MathML. Blahtexml is a simple extension of blahtex. In addition to
+the functionality of blahtex, blahtexml has XML processing in mind
+and is able to process a whole XML document into another XML
+document. Instead of converting only one formula at a time, blahtexml
+can convert all the formulas of the given XML file into MathML.
+.SH OPTIONS
+These programs follow the usual GNU command line syntax, with long
+options starting with two dashes (`-').
+A summary of options is included below.
+For a complete description, see the online documentation.
+.TP
+.B \-\-help
+Show summary of options.
+.TP
+.B \-\-texvc-compatible-commands
+Enables use of commands that are specific to texvc, but that are not
+standard TeX/LaTeX/AMS-LaTeX commands.
+.TP
+.B \-\-print-error-messages
+This will print out a list of all error IDs and corresponding messages
+that blahtex can possibly emit inside an <error> block.
+.SH MATHML OPTIONS
+These options control the MathML output of the blahtexml program.
+
+.TP
+.B \-\-mathml
+Enables MathML output.
+.TP
+.B \-\-xmlin
+This allows one to embed TeX equations in an existing MathML code, using
+a special notation. The equations are given as attributes (inline or block)
+in the http://gva.noekeon.org/blahtexml namespace. Whenever blahtexml meets
+such an equation, it expands it into the equivalent MathML code.
+
+For more information check
+.RS
+http://gva.noekeon.org/blahtexml/how_to_use.html
+.RE
+.RS
+or the blahtexml manual.
+.RE
+.TP
+.B \-\-annotate-TeX
+Produces TeX annotations in the MathML output.
+.TP
+.B \-\-annotate-PNG
+Produces PNG files and annotates the MathML output with the PNG file name.
+.SH SEE ALSO
+The program is documented fully by the
+online manual available at:
+http://gva.noekeon.org/blahtexml
+.SH AUTHOR
+blahtexml was written by Gilles Van Assche.
+.br
+blahtex (whose superset is blahtexml) was written by David Harvey.
+.PP
+This manual page was written by Abhishek Dasgupta <abhidg@gmail.com>,
+for the Debian project (but may be used by others).
+
diff --git a/app-text/blahtexml/metadata.xml b/app-text/blahtexml/metadata.xml
new file mode 100644
index 000000000000..bfcb6974f1c4
--- /dev/null
+++ b/app-text/blahtexml/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+</pkgmetadata>