summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-07-31 12:13:13 -0400
committerMatt Turner <mattst88@gentoo.org>2024-07-31 12:13:13 -0400
commitf300cb0f9df882f9df4f4a2e2b2979288dd53576 (patch)
tree4c1a5f5545d672203e8bcb57d8c5f8309ddd9ef8 /app-shells
parentx11-apps/xinput_calibrator: Version bump to 0.8.0 (diff)
downloadgentoo-f300cb0f9df882f9df4f4a2e2b2979288dd53576.tar.gz
gentoo-f300cb0f9df882f9df4f4a2e2b2979288dd53576.tar.bz2
gentoo-f300cb0f9df882f9df4f4a2e2b2979288dd53576.zip
app-shells/fzf: Version bump to 0.54.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fzf/Manifest2
-rw-r--r--app-shells/fzf/fzf-0.54.3.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/app-shells/fzf/Manifest b/app-shells/fzf/Manifest
index 8c5f74bb6101..32f33a6c1fdd 100644
--- a/app-shells/fzf/Manifest
+++ b/app-shells/fzf/Manifest
@@ -8,3 +8,5 @@ DIST fzf-0.54.0-deps.tar.xz 5882708 BLAKE2B 1d9ca4f000960c811b5c45c61c59469c19d6
DIST fzf-0.54.0.tar.gz 291944 BLAKE2B e960285192c055e2228f682216aaebe02751ab66d8e9aa2bb347d46c5fc4aaa6895236c0059b4085cac213e3f8516a0ce2e9e0427a834b1c74cc41df28a2d167 SHA512 ed136c12142ceb7fabb39bd8f2d5e408efc44d17fb94514d9677a0a47013dc488bafeb657b7d448533d487091db4bd4194510e99493f8b05b007560d8c59ee2c
DIST fzf-0.54.1-deps.tar.xz 5879212 BLAKE2B 438657b245e235122b14f07215160c4b89c161020656a1613e32e369a394a0d0e30373ebf656b0f634bbbbef46250a0b1a85cf211e5a52e0f4f98f22c58683e0 SHA512 78f66c9990512b7b26b8cd08c513bfde5a1768c9e084b9f604cd58f27140afc08c4bb12751328659981a1b33c81c5787e3ab5c96f121f5f675cf8fcbf1386fdf
DIST fzf-0.54.1.tar.gz 292157 BLAKE2B db3c48bfa4c9a1897e35a42be44c6f8e15979d356ea637682288569d8fb8976cccaead7602024701112d10f1d456b02730d938545dc791a73c78de11a68726d9 SHA512 0c35a25c27b55e0e9606536e191a6ebd721c247a5ca7f745edca123e6b9ba9ce8b672523eda5c7abfff9b06daa6e1055fd47f714e003ca3aca7d3f11d38386f3
+DIST fzf-0.54.3-deps.tar.xz 5875812 BLAKE2B 19e27c17c86ae5df2a84bfde2a7df912a3e1b4e46c1475da0d10b190df272de0f09b3e546c84bc78e012788bd0842125681e43fe090f244bbd538bf2c6050175 SHA512 29a006cdb8352090aeda6d15e020700d123a1fa1e125bb82058253054e0cefc2d52b055392b38ba9b262bf0802609a7d99b49f602081fb472f0d0c7d709fcc59
+DIST fzf-0.54.3.tar.gz 292944 BLAKE2B 4a2e7a6cc50504215fa14ef6559df8b14fa0d89a499ca06f25b170cd2456d22cc30260de80821db9525ba4d6ece24ab39d863f23004f680bd3cf1d2a6985ec25 SHA512 e93056c3030e4a9dca59066fe111ef7539040a2e5bb800030d8f3e032acfae7db5fd2cf32aa7a45b505ec180e95c05bebe801bfc60c65db15fe9b647959ea987
diff --git a/app-shells/fzf/fzf-0.54.3.ebuild b/app-shells/fzf/fzf-0.54.3.ebuild
new file mode 100644
index 000000000000..380854366f61
--- /dev/null
+++ b/app-shells/fzf/fzf-0.54.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="General-purpose command-line fuzzy finder, written in Golang"
+HOMEPAGE="https://github.com/junegunn/fzf"
+
+# For fancy versioning only. Bump on the next release!
+# MY_GIT_REV is the first 7 characters of release commit, we truncate it
+# after to make it easier to copy/paste.
+MY_GIT_REV=9e92b6f11e0f59272de410f56493893334071e6e
+MY_GIT_REV=${MY_GIT_REV:0:7}
+
+SRC_URI="https://github.com/junegunn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~mattst88/distfiles/${P}-deps.tar.xz"
+
+LICENSE="MIT BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+src_prepare() {
+ default
+ sed -i 's/-s -w //' Makefile || die # bug #795225
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}"/usr VERSION=${PV} REVISION=${MY_GIT_REV} bin/${PN}
+}
+
+src_install() {
+ dobin bin/${PN}
+ doman man/man1/${PN}.1
+
+ dobin bin/${PN}-tmux
+ doman man/man1/${PN}-tmux.1
+
+ insinto /usr/share/vim/vimfiles/plugin
+ doins plugin/${PN}.vim
+
+ insinto /usr/share/nvim/runtime/plugin
+ doins plugin/${PN}.vim
+
+ newbashcomp shell/completion.bash ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins shell/completion.zsh _${PN}
+
+ insinto /usr/share/fzf
+ doins shell/key-bindings.bash
+ doins shell/key-bindings.fish
+ doins shell/key-bindings.zsh
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To add fzf support to your shell, make sure to use the right file"
+ elog "from ${EROOT}/usr/share/fzf."
+ elog
+ elog "For bash, add the following line to ~/.bashrc:"
+ elog
+ elog " # source ${EROOT}/usr/share/bash-completion/completions/fzf"
+ elog " # source ${EROOT}/usr/share/fzf/key-bindings.bash"
+ elog
+ elog "Plugins for Vim and Neovim are installed to respective directories"
+ elog "and will work out of the box."
+ elog
+ elog "For fzf support in tmux see fzf-tmux(1)."
+ fi
+}