summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2024-08-10 14:56:40 +0900
committerAkinori Hattori <hattya@gentoo.org>2024-08-10 14:56:40 +0900
commitb91950edd39b604e9e04de6a5d8978c641e47e57 (patch)
tree30c7e0fe362df3a4f5cff421547f455b058e2c84 /app-shells
parentdev-ruby/mustermann: add 3.0.2 (diff)
downloadgentoo-b91950edd39b604e9e04de6a5d8978c641e47e57.tar.gz
gentoo-b91950edd39b604e9e04de6a5d8978c641e47e57.tar.bz2
gentoo-b91950edd39b604e9e04de6a5d8978c641e47e57.zip
app-shells/yash: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/yash/Manifest1
-rw-r--r--app-shells/yash/yash-2.57.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-shells/yash/Manifest b/app-shells/yash/Manifest
index c179afb6e521..5482ed6df6a3 100644
--- a/app-shells/yash/Manifest
+++ b/app-shells/yash/Manifest
@@ -1 +1,2 @@
DIST yash-2.56.1.tar.xz 768752 BLAKE2B 8ee4c654e85b5895096870afcb3fc4e855274f3fd1956372753a46c522430a59c8ba96e64b0b13672e0289d2a9b6492a18a0f3d9e9e5500f53144ed1d56ca750 SHA512 28e8bde5fc12e5178136b82ecdc0c52c37c98301245089b0d55c43266880e299237a5522e572883e5c51b7d9a0e9bf94fe265a9ebdbf346c28ff837b0f60cc00
+DIST yash-2.57.tar.xz 771228 BLAKE2B ea11d63c013a5b967ff32984e33b2b0113e3101b233d5923e902a15d1f1b53142f4266dd54df85776dd7ad45f4045c5cee500e7de764e92d2e2e87b7e2fbf19a SHA512 6604ce54f698740d99e4ce3e6ff93b10936353b0690871b4dd1a0ef4569fc228284f551398b4912d324c8627eccec4cd51ac58508f741eb47b315560f02bff01
diff --git a/app-shells/yash/yash-2.57.ebuild b/app-shells/yash/yash-2.57.ebuild
new file mode 100644
index 000000000000..9084d796b0ba
--- /dev/null
+++ b/app-shells/yash/yash-2.57.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PLOCALES="en ja"
+
+inherit flag-o-matic plocale toolchain-funcs
+
+DESCRIPTION="Yash is a POSIX-compliant command line shell"
+HOMEPAGE="https://magicant.github.io/yash/"
+SRC_URI="https://github.com/magicant/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="nls test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-libs/ncurses:=
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )
+ test? ( sys-apps/ed )"
+
+src_configure() {
+ append-cflags -std=c99
+
+ sh ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --exec-prefix="${EPREFIX}" \
+ $(use_enable nls) \
+ CC="$(tc-getCC)" \
+ LINGUAS="$(plocale_get_locales | sed "s/en/en@quot en@boldquot/")" \
+ || die
+}