summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Misbakh-Soloviov <mva@gentoo.org>2020-09-14 12:16:11 +0700
committerVadim Misbakh-Soloviov <mva@gentoo.org>2020-09-14 12:16:11 +0700
commit5cfe2cac99022c6d6d8b202dbdd66ec75ecb9916 (patch)
tree00d35fc1a92f01dc45b2dfbfe942f0db027d1c0b /app-shells
parentapp-emulation/lxd: remove old 4.0.2 (diff)
downloadgentoo-5cfe2cac99022c6d6d8b202dbdd66ec75ecb9916.tar.gz
gentoo-5cfe2cac99022c6d6d8b202dbdd66ec75ecb9916.tar.bz2
gentoo-5cfe2cac99022c6d6d8b202dbdd66ec75ecb9916.zip
app-shells/gentoo-zsh-completions: bump to the new version
Closes: https://bugs.gentoo.org/439978 Package-Manager: Portage-3.0.6, Repoman-2.3.20 Signed-off-by: Vadim Misbakh-Soloviov <mva@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/gentoo-zsh-completions/Manifest1
-rw-r--r--app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20200914.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-shells/gentoo-zsh-completions/Manifest b/app-shells/gentoo-zsh-completions/Manifest
index 0cadb7eac113..593849bd073f 100644
--- a/app-shells/gentoo-zsh-completions/Manifest
+++ b/app-shells/gentoo-zsh-completions/Manifest
@@ -1 +1,2 @@
DIST gentoo-zsh-completions-20180228.tar.gz 23246 BLAKE2B a6e4004aa7592cbb097cad55fe9d7286f39bd264d8c463ed22e665ca6a60732b0bc8678a0ac09715e2f34abbadd0e4466d783fdb228ce364bcbe13fb7f097649 SHA512 2b3dcfb910e297eb2f03f4ad9f3749b379ceb60f8b6cbcb7c7d03b7921b79aa21f8d3aa50931c5d4eff52f988a208f1a810c6da7c20720be7a3f2ce4a4564788
+DIST gentoo-zsh-completions-20200914.tar.gz 25823 BLAKE2B 2a4af0fe85819f5cb8b3669f5a3b5b0e9672864a1562641c1760b7fa889648d3b405d5e28fd863bcea7800faca3c7392ecf3c5169755345bbf75d17c996c0de2 SHA512 a7f65e255a3c9f342d266d3a8604645c117124bd3f714d90aa63b3f6f873a4cf46224d7a9969061fc522107139b97695b8bbeb8a6dcb360f41128079adf9ce8c
diff --git a/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20200914.ebuild b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20200914.ebuild
new file mode 100644
index 000000000000..ff98a19ddf2a
--- /dev/null
+++ b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20200914.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gentoo/gentoo-zsh-completions.git"
+else
+ SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris"
+fi
+
+DESCRIPTION="Gentoo specific zsh completion support (includes emerge and ebuild commands)"
+HOMEPAGE="https://github.com/gentoo/gentoo-zsh-completions"
+
+LICENSE="ZSH"
+SLOT="0"
+
+RDEPEND=">=app-shells/zsh-4.3.5"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+
+ dodoc AUTHORS
+}