summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2022-09-07 00:34:13 +0900
committerAkinori Hattori <hattya@gentoo.org>2022-09-07 00:34:13 +0900
commit40c7a391835ee215c06867d34a99eaa9963e91a3 (patch)
treee4fe2f11c579e16e1ea47202fb00f0f4868433bd /app-shells
parentapp-i18n/uim: new upstream release (diff)
downloadgentoo-40c7a391835ee215c06867d34a99eaa9963e91a3.tar.gz
gentoo-40c7a391835ee215c06867d34a99eaa9963e91a3.tar.bz2
gentoo-40c7a391835ee215c06867d34a99eaa9963e91a3.zip
app-shells/yash: new upstream release
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/yash/Manifest1
-rw-r--r--app-shells/yash/yash-2.53.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-shells/yash/Manifest b/app-shells/yash/Manifest
index bcb848198a17..4e7ca945b0fa 100644
--- a/app-shells/yash/Manifest
+++ b/app-shells/yash/Manifest
@@ -1 +1,2 @@
DIST yash-2.52.tar.xz 755016 BLAKE2B 44c26d310e9bd50a6f381adefedcdf9bcb49998860a8a67e300d31d5a8615d7346e06e7c4ca5e098d7232a0acc112daa2230572939f665db982f187ccd741778 SHA512 1024ff7e3cce6e64cbc0bd5c0d04a9863d0d51013baf07723d09562b156d05dbfe1fc2df5b736cdec5f562c56ad634f865554a1fe5aeeed91ec0d9276667f02a
+DIST yash-2.53.tar.xz 755956 BLAKE2B 191bdc6fcda7c3043d3db53b70fcdba86fab740df2aaf1249380c4679f51ec61b9a36c51a7982c516f51f8a2605729d7242d81f738523edfc07f21be1a06ff45 SHA512 9bc6dcc9864fbba6200b76dad50b9eb1620b578fceaea5d1dd34e2efda379be0e4255d56e49c9595dc184ddf45951418e87a88dc6507d41cc4220f38b7044994
diff --git a/app-shells/yash/yash-2.53.ebuild b/app-shells/yash/yash-2.53.ebuild
new file mode 100644
index 000000000000..fbee726df1c7
--- /dev/null
+++ b/app-shells/yash/yash-2.53.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PLOCALES="en ja"
+
+inherit flag-o-matic plocale toolchain-funcs
+
+DESCRIPTION="Yash is a POSIX-compliant command line shell"
+HOMEPAGE="https://yash.osdn.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/77664/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-libs/ncurses:=
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )
+ test? ( sys-apps/ed )"
+
+src_configure() {
+ append-cflags -std=c99
+
+ sh ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --exec-prefix="${EPREFIX}" \
+ $(use_enable nls) \
+ CC="$(tc-getCC)" \
+ LINGUAS="$(plocale_get_locales | sed "s/en/en@quot en@boldquot/")" \
+ || die
+}