summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2025-01-23 21:38:52 +0100
committerMaciej Barć <xgqt@gentoo.org>2025-01-23 23:10:36 +0100
commit3885b699b13ca04287ad40e9cae1f490554695a3 (patch)
treef6134637501564bb1bbf0127a8636031e20a36dc /app-shells
parentapp-shells/pwsh-bin: drop old 7.4.5 (diff)
downloadgentoo-3885b699b13ca04287ad40e9cae1f490554695a3.tar.gz
gentoo-3885b699b13ca04287ad40e9cae1f490554695a3.tar.bz2
gentoo-3885b699b13ca04287ad40e9cae1f490554695a3.zip
app-shells/pwsh-bin: bump to 7.4.7
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/pwsh-bin/Manifest3
-rw-r--r--app-shells/pwsh-bin/pwsh-bin-7.4.7.ebuild71
2 files changed, 74 insertions, 0 deletions
diff --git a/app-shells/pwsh-bin/Manifest b/app-shells/pwsh-bin/Manifest
index 18f0221fc90b..78fec1285670 100644
--- a/app-shells/pwsh-bin/Manifest
+++ b/app-shells/pwsh-bin/Manifest
@@ -1,3 +1,6 @@
DIST powershell-7.4.6-linux-arm32.tar.gz 69951436 BLAKE2B f14e3ac936bea8d79cb86dd92feec484afa87942c5d9a1a277c77d9bf23ab273053a4c6f903e9087ce4afd240cd2e2144033de18efd487733724cdf3767b877b SHA512 8f0c181c6194fe4a34d47fcef16af14ca69a647999746911a2f5d139186dc6d3f8faf87fdec307a895993364127aebc565b4ecb2fd098cf36aa2b09b3ce1227e
DIST powershell-7.4.6-linux-arm64.tar.gz 68949931 BLAKE2B 1e8a3f3299c0ca80aa2fe32f26ef495807201903ef19efb959ebce595c62807b7c51ead5ca625d72f46333e6f13b70adecc210805d9c965992c8c71dd8f9b0c7 SHA512 61bef872ed9873f6f0af76ffe2a3eece404961d58b13fae8c886458db9f348424369761e308b24e6fa348ad4ed220168331743c528c0c04760933a950ab04afe
DIST powershell-7.4.6-linux-x64.tar.gz 71645796 BLAKE2B 7bf99d83dabf5b599699395715bee094f1b414e4603022f962b2372f4f4f61c10c1afbf47b9dd86aadfa17e2a917ef4e6dfd5011a5fecb37b0dbf123f6dfc51d SHA512 0a449f458bafeeacb3c410d83ce2f89f117f001a4b4a18b57dd3282ac358f382a13019657343f66a5cbd9c23b93df346823ac5337393d1addc948d550d3bf89d
+DIST powershell-7.4.7-linux-arm32.tar.gz 69566132 BLAKE2B c835f9bce5914c3741614ebcae9de39592c6ed37526d2d4fba4d8701fbcce54c63586e574847185b9fe3ba4861f8c839a61de08545a95ef726834d9a931deef2 SHA512 d8f56c665dd5a7830cd84345a24d557c0025b9b7b8df45477c69891994ec6c4079f951a2849f011df15f17a3262d05f925d50ef038e3838c6dbe92f2631b1e61
+DIST powershell-7.4.7-linux-arm64.tar.gz 68539779 BLAKE2B 24eaaf5beae9d1c70b9fe3e7b64a4edf5fbda1293c0b4327e46495c2d51db0a7e11d5a723a1d8e0f17c88a49e1db7dfaa4661fa1326659ba321dda5264f7fc32 SHA512 2bc4f8d840f05ca3246ede9d291af6596321669eff7c1a936a37c853053e3cef68ecb23b50e496a3804e1b0d204cc89685ce403538e6d06910f634262f68529c
+DIST powershell-7.4.7-linux-x64.tar.gz 71281502 BLAKE2B 5e68137b31c04b31f0146037c59708009e9d7e7b1e4f5baa14335a45217a77c1f6d6e98b6ce552db303a2edaef0ec58ecc25cfa9165ce1a975f906430e20a464 SHA512 523d778a45ee01be48b97bdfd6b46b58a93b0cb1643f50c531ace8f5a53dd7e8f9bef07e5e715a9969280db04aa18afb5002ae27a9b968dc04952abd78583da2
diff --git a/app-shells/pwsh-bin/pwsh-bin-7.4.7.ebuild b/app-shells/pwsh-bin/pwsh-bin-7.4.7.ebuild
new file mode 100644
index 000000000000..07a48bba2c9f
--- /dev/null
+++ b/app-shells/pwsh-bin/pwsh-bin-7.4.7.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit wrapper
+
+DESCRIPTION="Cross-platform automation and configuration tool (binary package)"
+HOMEPAGE="https://microsoft.com/powershell/
+ https://github.com/PowerShell/PowerShell/"
+
+BASE_URI="https://github.com/PowerShell/PowerShell/releases/download/"
+SRC_URI="
+ amd64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-x64.tar.gz )
+ arm64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm64.tar.gz )
+ arm? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm32.tar.gz )
+"
+S="${WORKDIR}"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64"
+REQUIRED_USE="elibc_glibc"
+
+RDEPEND="
+ app-crypt/mit-krb5:0/0
+ dev-libs/icu
+ dev-util/lttng-ust:0/2.12
+ sys-libs/pam:0/0
+ sys-libs/zlib:0/1
+ || (
+ dev-libs/openssl-compat:1.0.0
+ =dev-libs/openssl-1.0*:0/0
+ )
+"
+IDEPEND="
+ app-eselect/eselect-pwsh
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ local -a broken_symlinks
+ broken_symlinks=( libcrypto.so.1.0.0 libssl.so.1.0.0 )
+
+ local symlink
+ for symlink in "${broken_symlinks[@]}" ; do
+ if [[ -L "${symlink}" ]] ; then
+ rm "${symlink}" || die "failed to remove ${symlink}"
+ fi
+ done
+
+ local dest="opt/${PN}-${SLOT}"
+ local dest_root="/${dest}"
+
+ insinto "${dest_root}"
+ doins -r .
+
+ fperms 0755 "${dest_root}/pwsh"
+
+ local gentoo_path='PSModulePath="${PSModulePath}:${EPREFIX}/usr/share/GentooPowerShell/Modules:"'
+ make_wrapper "${PN}-${SLOT}" "env ${gentoo_path} ${dest_root}/pwsh"
+}
+
+pkg_postinst() {
+ eselect pwsh update ifunset
+}
+
+pkg_postrm() {
+ eselect pwsh update ifunset
+}