summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-08 21:52:37 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-08 21:52:37 +0100
commit15435e3094fd0cdc64e26a6a205f9395bf8e3ec2 (patch)
tree70049b9d4d80d056123de767fd509863644ffdfa /app-portage
parentdev-python/botocore: Add a dependency on dev-python/requests (diff)
downloadgentoo-15435e3094fd0cdc64e26a6a205f9395bf8e3ec2.tar.gz
gentoo-15435e3094fd0cdc64e26a6a205f9395bf8e3ec2.tar.bz2
gentoo-15435e3094fd0cdc64e26a6a205f9395bf8e3ec2.zip
app-portage/gpyutils: Bump to 0.13.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gpyutils/Manifest1
-rw-r--r--app-portage/gpyutils/gpyutils-0.13.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-portage/gpyutils/Manifest b/app-portage/gpyutils/Manifest
index 17fa4bd93236..e4c66c7a869f 100644
--- a/app-portage/gpyutils/Manifest
+++ b/app-portage/gpyutils/Manifest
@@ -1 +1,2 @@
+DIST gpyutils-0.13.1.gh.tar.gz 31758 BLAKE2B a7eb282dff3b65e7cdf50c3ae5d787a4cdc49bda2030d88525b5d1752eafb5b9548873832512f3b9449eeef26198adea89b8e339e997a002eea32215c8a5b783 SHA512 0126f6f1253d39dca6ff2c2191c44831c562494883b8d6e48b6b313914689f5389acc2fde2eba21d538a452d3eea3ee92057ca1ba2edb72bd293b6731f4959ef
DIST gpyutils-0.13.gh.tar.gz 31679 BLAKE2B 1fa15fdccf5c36a45294c946035e9d3a7205844625785dc3e70247742a0202610088f810f9114d84e519383aca197cd7538606e45ed934a1d676df499e22d45a SHA512 510f85b920e7d3525ee6ae4cf8505c81e22d157e0d968b88925e79eace1b156f76e14d8374e9187254cdc228db24b1fda9482eeac26173be5d5997dfe7c1596c
diff --git a/app-portage/gpyutils/gpyutils-0.13.1.ebuild b/app-portage/gpyutils/gpyutils-0.13.1.ebuild
new file mode 100644
index 000000000000..2203d0b564b2
--- /dev/null
+++ b/app-portage/gpyutils/gpyutils-0.13.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Utitilies for maintaining Python packages"
+HOMEPAGE="
+ https://github.com/projg2/gpyutils/
+ https://pypi.org/project/gpyutils/
+"
+SRC_URI="
+ https://github.com/projg2/gpyutils/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=app-portage/gentoopm-0.3.2[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest