summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-portage/pqlop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-portage/pqlop')
-rw-r--r--app-portage/pqlop/Manifest1
-rw-r--r--app-portage/pqlop/metadata.xml17
-rw-r--r--app-portage/pqlop/pqlop-0.02-r1.ebuild35
3 files changed, 53 insertions, 0 deletions
diff --git a/app-portage/pqlop/Manifest b/app-portage/pqlop/Manifest
new file mode 100644
index 000000000000..688cfccaf973
--- /dev/null
+++ b/app-portage/pqlop/Manifest
@@ -0,0 +1 @@
+DIST pqlop-0.02.py 14920 SHA256 aeeeeab1e5d38a694c80401472506e95a10f4ffada70765b9737d6f8f0f6c543 SHA512 6c2cca73b5280ac8563573a81baff56cf43420c18688fae497ff014ec5668806d589473a2cb8093fdc07675761e8c4124f18eb568a74e1816f573541459d633f WHIRLPOOL fedf6a863b02a74017eb40a3175a377f8e4b96c2e7f1c09e516769cf6c30dff60ca96d586d27ac17442e9194a401f9a4a7011af7b5aef939bee38e6837829dc6
diff --git a/app-portage/pqlop/metadata.xml b/app-portage/pqlop/metadata.xml
new file mode 100644
index 000000000000..eaa80b067831
--- /dev/null
+++ b/app-portage/pqlop/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>lk4d4math@gmail.com</email>
+ <name>Alexandr Morozov</name>
+ <description>Author and maintainer of package</description>
+ </maintainer>
+ <maintainer>
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="bitbucket">LK4D4/pqlop</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-portage/pqlop/pqlop-0.02-r1.ebuild b/app-portage/pqlop/pqlop-0.02-r1.ebuild
new file mode 100644
index 000000000000..63e7f4447cb4
--- /dev/null
+++ b/app-portage/pqlop/pqlop-0.02-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit python-r1
+
+DESCRIPTION="emerge.log parser written in python"
+HOMEPAGE="https://bitbucket.org/LK4D4/pqlop"
+SRC_URI="https://bitbucket.org/LK4D4/pqlop/raw/${PV}/pqlop.py -> ${P}.py"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ ${PYTHON_DEPS}
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ newbin "${DISTDIR}"/${P}.py ${PN} || die "newbin failed"
+ python_replicate_script "${ED}"/usr/bin/${PN} || die "python_replicate_script failed"
+}