summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-09 13:35:40 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-09 13:36:18 +0200
commitcace5211fb17a19690307cd33b11d176e37408a7 (patch)
treea46a68590eb1d8af4798edc5364470d55d9dfc91 /app-portage/gpyutils
parentkde-plasma/breeze-gtk: drop 5.27.4 (diff)
downloadgentoo-cace5211fb17a19690307cd33b11d176e37408a7.tar.gz
gentoo-cace5211fb17a19690307cd33b11d176e37408a7.tar.bz2
gentoo-cace5211fb17a19690307cd33b11d176e37408a7.zip
app-portage/gpyutils: Bump to 0.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/gpyutils')
-rw-r--r--app-portage/gpyutils/Manifest1
-rw-r--r--app-portage/gpyutils/gpyutils-0.9.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-portage/gpyutils/Manifest b/app-portage/gpyutils/Manifest
index 9f03c5c4be90..87c417390048 100644
--- a/app-portage/gpyutils/Manifest
+++ b/app-portage/gpyutils/Manifest
@@ -1 +1,2 @@
DIST gpyutils-0.8.4.gh.tar.gz 20477 BLAKE2B 661ec8c9ae595daa112de2171331a5791fa4a10b50f9ebf76589c4c6ff4d6b8e618657dd9f3dd6cf573871ab6e0a9d017d87e03066fa60ba8b9d4e4617f68306 SHA512 f87a087464ca8e1118232227d2e6ad66aa021caabf0307c153b442fc4467bd124eb918c16104bdd1b42866acde16fdde4b99312a8c047ecf379ed10a74d27541
+DIST gpyutils-0.9.gh.tar.gz 24680 BLAKE2B 75f2ebf3a4ed3883aa3c28773edb903ef2063ad0b6c55316578b2fbf725317ec84a1e0017637d36f28903043ff9d82c2b298bbc8424576b1e23c76f5d3107b59 SHA512 306e2e0a9abe95b6dc526b7b04ec7451a7a33e59542c6a0ac12860eadee8501f0e9ff42586dd3df2c5d43e44a43c458665456ba65c435075d3fbbde31b0314b0
diff --git a/app-portage/gpyutils/gpyutils-0.9.ebuild b/app-portage/gpyutils/gpyutils-0.9.ebuild
new file mode 100644
index 000000000000..63c9e0a53111
--- /dev/null
+++ b/app-portage/gpyutils/gpyutils-0.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Utitilies for maintaining Python packages"
+HOMEPAGE="
+ https://github.com/projg2/gpyutils/
+ https://pypi.org/project/gpyutils/
+"
+SRC_URI="
+ https://github.com/projg2/gpyutils/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=app-portage/gentoopm-0.3.2[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest