summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-27 10:11:06 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-27 10:35:19 +0100
commit4becb9b2eea2003ecff189b5c9a73ecb521f3603 (patch)
tree3a95d03e562239679c86293e8348d2a7a0b62eed /app-portage/gentoopm
parentdev-python/aesara: Bump to 2.0.4 (diff)
downloadgentoo-4becb9b2eea2003ecff189b5c9a73ecb521f3603.tar.gz
gentoo-4becb9b2eea2003ecff189b5c9a73ecb521f3603.tar.bz2
gentoo-4becb9b2eea2003ecff189b5c9a73ecb521f3603.zip
app-portage/gentoopm: Bump to 0.3.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/gentoopm')
-rw-r--r--app-portage/gentoopm/Manifest1
-rw-r--r--app-portage/gentoopm/gentoopm-0.3.3.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-portage/gentoopm/Manifest b/app-portage/gentoopm/Manifest
index b9eac26a9df1..4900dd6102c5 100644
--- a/app-portage/gentoopm/Manifest
+++ b/app-portage/gentoopm/Manifest
@@ -1 +1,2 @@
DIST gentoopm-0.3.2.tar.gz 38430 BLAKE2B df8536b384cdad754894d65b605ab688cedc09430bcc3cd0821ed1ae9a93d0cb5e7b076715edf6eaed6bbf5ffc9088fb14d8bd5a04c3809c38ce05c6ed106bb9 SHA512 d99034af2efada3647117c75d5602bc5878a8f0e79d1c6b502fdb0fa272f7b9148afbbe4d379a2957a7db6694b4001158e2dfce8e3a4f97692e20a803417f571
+DIST gentoopm-0.3.3.tar.gz 38624 BLAKE2B 018be741c6970b17525e56d5acdb23e15c8f78016fddda50ef329ea65b84e085a928e1e5e95c69757530c067c28aa578e9c56b8bd7546d7249a75e9c3cc3b57f SHA512 91ea07035b25bdccd8072c5691690ae0b40b6220a2ea29e4b051aeb8455f200e94569036af42ff2f5d7714344d332e5d71e3ff8dfde811f2aa6b6c1b3a895b21
diff --git a/app-portage/gentoopm/gentoopm-0.3.3.ebuild b/app-portage/gentoopm/gentoopm-0.3.3.ebuild
new file mode 100644
index 000000000000..9cd209e62733
--- /dev/null
+++ b/app-portage/gentoopm/gentoopm-0.3.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A common interface to Gentoo package managers"
+HOMEPAGE="https://github.com/mgorny/gentoopm/"
+SRC_URI="https://github.com/mgorny/gentoopm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+IUSE=""
+
+RDEPEND="
+ || (
+ >=sys-apps/pkgcore-0.9.4[${PYTHON_USEDEP}]
+ >=sys-apps/portage-2.1.10.3[${PYTHON_USEDEP}] )"
+PDEPEND="app-eselect/eselect-package-manager"
+
+python_test() {
+ esetup.py test
+}