summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-03-28 13:29:57 +0000
committerJames Le Cuirot <chewi@gentoo.org>2020-03-28 13:31:49 +0000
commit4805099cb791315b53f0416b336b35b116f183f6 (patch)
tree79f6c68c43ae7391705686e3f01a8c6cb626c601 /app-pda
parentmedia-gfx/iscan: Depend on imagemagick[cxx], bug 713554 (diff)
downloadgentoo-4805099cb791315b53f0416b336b35b116f183f6.tar.gz
gentoo-4805099cb791315b53f0416b336b35b116f183f6.tar.bz2
gentoo-4805099cb791315b53f0416b336b35b116f183f6.zip
app-pda/libplist: Don't prefer clang in 2.1.0
Closes: https://bugs.gentoo.org/714076 Package-Manager: Portage-2.3.96, Repoman-2.3.20 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/libplist/libplist-2.1.0.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/app-pda/libplist/libplist-2.1.0.ebuild b/app-pda/libplist/libplist-2.1.0.ebuild
index c3222d610875..7b342d04b16d 100644
--- a/app-pda/libplist/libplist-2.1.0.ebuild
+++ b/app-pda/libplist/libplist-2.1.0.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit autotools python-r1
+inherit autotools python-r1 toolchain-funcs
DESCRIPTION="Support library to deal with Apple Property Lists (Binary & XML)"
HOMEPAGE="https://www.libimobiledevice.org/"
@@ -49,13 +49,16 @@ src_configure() {
do_configure "$@"
}
+ # Don't prefer clang.
+ tc-export CC CXX
+
do_configure --without-cython
use python && python_foreach_impl do_configure_python
}
src_compile() {
python_compile() {
- emake -C "${BUILD_DIR}"/cython -j1 \
+ emake -C "${BUILD_DIR}"/cython \
VPATH="${S}/cython:${native_builddir}/cython" \
plist_la_LIBADD="${native_builddir}/src/libplist.la"
}
@@ -73,7 +76,7 @@ src_test() {
src_install() {
python_install() {
- emake -C "${BUILD_DIR}/cython" -j1 \
+ emake -C "${BUILD_DIR}/cython" \
VPATH="${S}/cython:${native_builddir}/cython" \
DESTDIR="${D}" install
}