summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-21 16:25:12 +0100
committerSam James <sam@gentoo.org>2023-08-21 16:51:09 +0100
commitca082bdd4768c1eada06c19fbd76cffb8352a067 (patch)
tree7fe45dde99ecf38597ea33162082516307da8127 /app-office
parentx11-misc/fracplanet: fix building against musl (diff)
downloadgentoo-ca082bdd4768c1eada06c19fbd76cffb8352a067.tar.gz
gentoo-ca082bdd4768c1eada06c19fbd76cffb8352a067.tar.bz2
gentoo-ca082bdd4768c1eada06c19fbd76cffb8352a067.zip
app-office/libreoffice: bundle abseil-cpp
abseil isn't *really* intended to be a system library and having a year-old pinned dep like this causes havoc for other packages and leads to uninstallable combinations (e.g. libreoffice-bin + anything needing grpc). Please see also the extensive discussion in the linked PRs wrt abseil now depending on re2 and the ABI implications of the used C++ std. versions with abseil. It's not worth it and there's more downsides to unbundling than not. Bug: https://github.com/gentoo/gentoo/pull/31388 Bug: https://github.com/gentoo/gentoo/pull/31609 Bug: https://github.com/gentoo/gentoo/pull/31893 Bug: https://github.com/gentoo/gentoo/pull/32281 Bug: https://bugs.gentoo.org/908373 Closes: https://bugs.gentoo.org/912686 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/libreoffice-7.5.9999.ebuild3
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild3
2 files changed, 2 insertions, 4 deletions
diff --git a/app-office/libreoffice/libreoffice-7.5.9999.ebuild b/app-office/libreoffice/libreoffice-7.5.9999.ebuild
index df73586c96e8..e79d7470ac97 100644
--- a/app-office/libreoffice/libreoffice-7.5.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-7.5.9999.ebuild
@@ -125,7 +125,6 @@ COMMON_DEPEND="${PYTHON_DEPS}
app-text/libwpg:0.3
>=app-text/libwps-0.4
app-text/mythes
- dev-cpp/abseil-cpp:=
>=dev-cpp/clucene-2.3.3.4-r2
>=dev-cpp/libcmis-0.5.2-r2
dev-db/unixODBC
@@ -494,7 +493,6 @@ src_configure() {
--with-external-tar="${DISTDIR}"
--with-lang=""
--with-parallelism=$(makeopts_jobs)
- --with-system-abseil
--with-system-openjpeg
--with-tls=nss
--with-vendor="Gentoo Foundation"
@@ -504,6 +502,7 @@ src_configure() {
--with-help="html"
--without-helppack-integration
--with-system-gpgmepp
+ --without-system-abseil
--without-system-dragonbox
--without-system-jfreereport
--without-system-libfixmath
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index 1b0074df9454..834e9e736aa9 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -124,7 +124,6 @@ COMMON_DEPEND="${PYTHON_DEPS}
app-text/libwpg:0.3
>=app-text/libwps-0.4
app-text/mythes
- dev-cpp/abseil-cpp:=
>=dev-cpp/clucene-2.3.3.4-r2
>=dev-cpp/libcmis-0.5.2-r2
dev-db/unixODBC
@@ -490,7 +489,6 @@ src_configure() {
--with-external-tar="${DISTDIR}"
--with-lang=""
--with-parallelism=$(makeopts_jobs)
- --with-system-abseil
--with-system-openjpeg
--with-tls=nss
--with-vendor="Gentoo Foundation"
@@ -500,6 +498,7 @@ src_configure() {
--with-help="html"
--without-helppack-integration
--with-system-gpgmepp
+ --without-system-abseil
--without-system-dragonbox
--without-system-jfreereport
--without-system-libfixmath