summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-02-29 18:32:47 -0500
committerSam James <sam@gentoo.org>2024-02-29 23:57:39 +0000
commit97ba9187a8c14f6773d4402d4681bb0c66157990 (patch)
tree78e821e785fe2f700ce37369b1efbd2049a7f5c3 /app-office/libalkimia
parentapp-text/pspdftool: mark LTO-unsafe, mark strict-aliasing unsafe (diff)
downloadgentoo-97ba9187a8c14f6773d4402d4681bb0c66157990.tar.gz
gentoo-97ba9187a8c14f6773d4402d4681bb0c66157990.tar.bz2
gentoo-97ba9187a8c14f6773d4402d4681bb0c66157990.zip
app-office/libalkimia: remove gmp USE flag, force it instead of mpir
mpir is an ancient fork of gmp from 2017. It claims to be focused on speed. It doesn't build with modern compilers due to Modern C issues, and it fails to build with LTO as well. Unlike gmp, this will never be fixed. Bug: https://bugs.gentoo.org/812950 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office/libalkimia')
-rw-r--r--app-office/libalkimia/libalkimia-8.1.2-r1.ebuild (renamed from app-office/libalkimia/libalkimia-8.1.2.ebuild)7
1 files changed, 3 insertions, 4 deletions
diff --git a/app-office/libalkimia/libalkimia-8.1.2.ebuild b/app-office/libalkimia/libalkimia-8.1.2-r1.ebuild
index 80739e14494a..686cdec755c3 100644
--- a/app-office/libalkimia/libalkimia-8.1.2.ebuild
+++ b/app-office/libalkimia/libalkimia-8.1.2-r1.ebuild
@@ -20,9 +20,10 @@ https://community.kde.org/Alkimia"
LICENSE="LGPL-2.1"
SLOT="0/8"
-IUSE="doc gmp plasma webengine"
+IUSE="doc plasma webengine"
DEPEND="
+ dev-libs/gmp:0=[cxx(+)]
>=dev-qt/qtdbus-${QTMIN}:5
>=dev-qt/qtdeclarative-${QTMIN}:5
>=dev-qt/qtgui-${QTMIN}:5
@@ -39,8 +40,6 @@ DEPEND="
>=kde-frameworks/ktextwidgets-${KFMIN}:5
>=kde-frameworks/kwidgetsaddons-${KFMIN}:5
>=kde-frameworks/kxmlgui-${KFMIN}:5
- !gmp? ( sci-libs/mpir:=[cxx] )
- gmp? ( dev-libs/gmp:0=[cxx(+)] )
plasma? (
>=kde-frameworks/kpackage-${KFMIN}:5
>=kde-plasma/libplasma-${KFMIN}:5
@@ -61,7 +60,7 @@ src_configure() {
-DBUILD_TOOLS=ON
-DBUILD_WITH_WEBKIT=OFF
$(cmake_use_find_package doc Doxygen)
- $(cmake_use_find_package !gmp MPIR)
+ -DCMAKE_DISABLE_FIND_PACKAGE_MPIR=ON
-DBUILD_APPLETS=$(usex plasma)
-DBUILD_WITH_WEBENGINE=$(usex webengine)
)