summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-02-15 17:15:33 -0300
committerMart Raudsepp <leio@gentoo.org>2024-02-17 17:55:37 +0200
commit84398a5fea60d5500bc0aa9ab956992f4b65f219 (patch)
treea69ac851f7cae3ab61067fe8aa86811a08c2b52b /app-office/gnumeric
parentx11-libs/goffice: Version bump to 0.10.57 (diff)
downloadgentoo-84398a5fea60d5500bc0aa9ab956992f4b65f219.tar.gz
gentoo-84398a5fea60d5500bc0aa9ab956992f4b65f219.tar.bz2
gentoo-84398a5fea60d5500bc0aa9ab956992f4b65f219.zip
app-office/gnumeric: Version bump to 1.12.57
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/35355 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'app-office/gnumeric')
-rw-r--r--app-office/gnumeric/Manifest1
-rw-r--r--app-office/gnumeric/gnumeric-1.12.57.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/app-office/gnumeric/Manifest b/app-office/gnumeric/Manifest
index 412bb488745c..b26b7e9b6f24 100644
--- a/app-office/gnumeric/Manifest
+++ b/app-office/gnumeric/Manifest
@@ -1,2 +1,3 @@
DIST gnumeric-1.12.55.tar.xz 18157492 BLAKE2B 6c084f681e33f00af80cc11dbddf33166877ca30480ae6fc6b65a0ef06271c634e2ba24af55df4c6b306833e2611e959dcbd8b117c97bbf46598419ed4d124e4 SHA512 04127a353d5109e3a31d9a3bd42d6d177366cc6c5d900516b4c8a7a8fcaecc71bd4e2e94876719246841070964b393af97988cafbd6313cea135c1757889e878
DIST gnumeric-1.12.56.tar.xz 18125644 BLAKE2B 0b43ed53dd544dda76ae1401d329f8b029f16117dafb4c2f939c1c48bf61d035e17692485df4034ce77a63031c5477aefd307a04d756c3017fed47354acb4f8a SHA512 badcba4cb08627628c216e4f2429c361d3d8ec7f653b6dda8a451356c798dc0cf323348c0272696a02bd47dd97b95bde0e7b23551cc0f63d8bf470dca219be0d
+DIST gnumeric-1.12.57.tar.xz 18149400 BLAKE2B d268cd2ac260e13be51bca53f4456b9db4d67376c34d15dd6483c1c697f6418120fc31630894fe037979a46277d557fd7b66f226d92d8ab414d87c9c5e27b53f SHA512 67886aff17338c41997cb71d2ee8fcac0f3b9dfc4ef1897b50866844e002ba7867f263daa3aadcaa10ba29746795fad0a4f852bdc22cdd4bc41293c952b69e9d
diff --git a/app-office/gnumeric/gnumeric-1.12.57.ebuild b/app-office/gnumeric/gnumeric-1.12.57.ebuild
new file mode 100644
index 000000000000..5a9dbd36d70d
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.57.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit autotools gnome.org python-r1 xdg
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://www.gnumeric.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+introspection libgda perl"
+REQUIRED_USE="introspection? ( ${PYTHON_REQUIRED_USE} )"
+
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, also fails tests due to 80-bit long story
+# upstream bug #721556
+RESTRICT="test"
+
+# Gnumeric has two python components
+# 1. The python loader for loading python-based plugins.
+# This component is pure python 2 and a port "is not currently being worked on".
+# 2. The python gobject-based introspection API. This component is compatible
+# with python 3.
+# Component 1. can only be re-enabled once someone has ported the upstream
+# codebase to python 3.
+# https://gitlab.gnome.org/GNOME/gnumeric/issues/419#note_618852
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.40.0:2
+ >=gnome-extra/libgsf-1.14.33:=
+ >=x11-libs/goffice-0.10.55:0.10[introspection?]
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.8.7:3
+ x11-libs/cairo:=[svg(+)]
+
+ introspection? (
+ ${PYTHON_DEPS}
+ >=dev-libs/gobject-introspection-1:=
+ )
+ perl? ( dev-lang/perl:= )
+ libgda? ( gnome-extra/libgda:5[gtk] )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ app-text/yelp-tools
+ dev-build/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Manage gi overrides ourselves
+ sed '/SUBDIRS/ s/introspection//' -i Makefile.{am,in} || die
+
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-gtk-doc \
+ --disable-maintainer-mode \
+ --disable-schemas-compile \
+ --disable-static \
+ --without-psiconv \
+ --without-python \
+ --with-zlib \
+ $(use_with libgda gda) \
+ $(use_enable introspection) \
+ $(use_with perl)
+}
+
+src_install() {
+ default
+ dodoc HACKING MAINTAINERS
+
+ if use introspection; then
+ python_moduleinto gi.overrides
+ python_foreach_impl python_domodule introspection/gi/overrides/Gnm.py
+ fi
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}