summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-04-27 23:59:52 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-04-28 00:01:46 -0400
commitbef10654f61f1196d2cbe28987c040b5c88360a9 (patch)
tree1591f7343bbdd71f3767909d915d7c5315291881 /app-misc/gramps/gramps-4.2.5.ebuild
parentdev-python/whelk: Version bump (diff)
downloadgentoo-bef10654f61f1196d2cbe28987c040b5c88360a9.tar.gz
gentoo-bef10654f61f1196d2cbe28987c040b5c88360a9.tar.bz2
gentoo-bef10654f61f1196d2cbe28987c040b5c88360a9.zip
app-misc/gramps: new version 4.2.5.
This is a straightforward version bump, except that I've eliminated one patch. By passing the --resourcepath argument to distutils, we avoid the need to patch it ourselves. Gentoo-Bug: 616796 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-misc/gramps/gramps-4.2.5.ebuild')
-rw-r--r--app-misc/gramps/gramps-4.2.5.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-misc/gramps/gramps-4.2.5.ebuild b/app-misc/gramps/gramps-4.2.5.ebuild
new file mode 100644
index 000000000000..6abcc0c4b44e
--- /dev/null
+++ b/app-misc/gramps/gramps-4.2.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5} )
+
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1
+
+DESCRIPTION="Genealogical Research and Analysis Management Programming System"
+HOMEPAGE="https://gramps-project.org/"
+SRC_URI="https://github.com/gramps-project/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+reports exif geo spell"
+
+RDEPEND="
+ dev-python/bsddb3[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.12:3[cairo,${PYTHON_USEDEP}]
+ dev-python/pyicu[${PYTHON_USEDEP}]
+ gnome-base/librsvg:2
+ >x11-libs/gtk+-3.14.8:3[introspection]
+ x11-libs/pango[introspection]
+ x11-misc/xdg-utils
+ reports? ( media-gfx/graphviz )
+ exif? ( >=media-libs/gexiv2-0.5[${PYTHON_USEDEP},introspection] )
+ geo? ( >=sci-geosciences/osm-gps-map-1.1.0 )
+ spell? ( app-text/gtkspell:3[introspection] )
+"
+
+python_configure_all() {
+ mydistutilsargs=( --resourcepath=/usr/share )
+}
+
+python_prepare_all() {
+ # Install documentation to the proper location. This can't be done
+ # easily with a patch because we substitute in the $PF variable,
+ # and that changes with every revision.
+ sed -i "s:share/doc/gramps:share/doc/${PF}:g" setup.py || die
+ distutils-r1_python_prepare_all
+}