summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYongxiang Liang <tanekliang@gmail.com>2024-01-10 01:12:12 +0800
committerYixun Lan <dlan@gentoo.org>2024-01-13 23:52:29 +0000
commit423bad3d701164f3146638ebe39a49886957bba0 (patch)
tree065fe4833bc32fa492335156a9431f5e6c0b9b30 /app-i18n/fcitx-anthy/fcitx-anthy-5.1.3.ebuild
parentapp-i18n/fcitx-hangul: add 5.1.1 (diff)
downloadgentoo-423bad3d701164f3146638ebe39a49886957bba0.tar.gz
gentoo-423bad3d701164f3146638ebe39a49886957bba0.tar.bz2
gentoo-423bad3d701164f3146638ebe39a49886957bba0.zip
app-i18n/fcitx-anthy: add 5.1.3
Closes: https://github.com/gentoo/gentoo/pull/34477 Signed-off-by: Yongxiang Liang <tanekliang@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-i18n/fcitx-anthy/fcitx-anthy-5.1.3.ebuild')
-rw-r--r--app-i18n/fcitx-anthy/fcitx-anthy-5.1.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-i18n/fcitx-anthy/fcitx-anthy-5.1.3.ebuild b/app-i18n/fcitx-anthy/fcitx-anthy-5.1.3.ebuild
new file mode 100644
index 000000000000..e6bd0e32b521
--- /dev/null
+++ b/app-i18n/fcitx-anthy/fcitx-anthy-5.1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="fcitx5-anthy"
+
+inherit cmake xdg
+
+DESCRIPTION="Japanese Anthy input methods for Fcitx5"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5-anthy"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-i18n/anthy
+ >=app-i18n/fcitx-5.1.6:5
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+DOCS=( AUTHORS )