summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/anthy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/anthy')
-rw-r--r--app-i18n/anthy/Manifest1
-rw-r--r--app-i18n/anthy/anthy-9100h-r1.ebuild64
-rw-r--r--app-i18n/anthy/files/50anthy-gentoo.el5
-rw-r--r--app-i18n/anthy/files/anthy-9100h-anthy_context_t.patch12
-rw-r--r--app-i18n/anthy/metadata.xml21
5 files changed, 103 insertions, 0 deletions
diff --git a/app-i18n/anthy/Manifest b/app-i18n/anthy/Manifest
new file mode 100644
index 000000000000..956a3edb9c0d
--- /dev/null
+++ b/app-i18n/anthy/Manifest
@@ -0,0 +1 @@
+DIST anthy-9100h.tar.gz 4446148 SHA256 d256f075f018b4a3cb0d165ed6151fda4ba7db1621727e0eb54569b6e2275547 SHA512 315ebd9e1af208f3ecaeaa13620213b35f004e47edb54e60c3e02c2997444cd2326cc58b725dd2d0bd6a723130884d946ea193ea3d92418082256b59ecc8d88b WHIRLPOOL dfdaa96e19dbd53ad627c40521922c7df74858e9836a770059dbd6005a09e3978bcd46bcd40380360708c4234e91e77d91161064614596047f53020c2c571245
diff --git a/app-i18n/anthy/anthy-9100h-r1.ebuild b/app-i18n/anthy/anthy-9100h-r1.ebuild
new file mode 100644
index 000000000000..da419e7bbec3
--- /dev/null
+++ b/app-i18n/anthy/anthy-9100h-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit elisp-common eutils
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/37536/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+#KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+SLOT="0"
+IUSE="canna-2ch emacs static-libs"
+
+DEPEND="!app-i18n/anthy-ss
+ canna-2ch? ( app-dicts/canna-2ch )
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-anthy_context_t.patch"
+
+ if use canna-2ch; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ sed -i \
+ -e "/set_input_encoding eucjp/aread ${EPREFIX}/var/lib/canna/dic/canna/nichan.ctd" \
+ mkworddic/dict.args.in || die
+ fi
+}
+
+src_configure() {
+ local myconf
+
+ use emacs || myconf="EMACS=no"
+
+ econf \
+ $(use_enable static-libs static) \
+ ${myconf} || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use emacs ; then
+ elisp-site-file-install "${FILESDIR}"/50anthy-gentoo.el || die
+ fi
+
+ dodoc AUTHORS DIARY NEWS README ChangeLog || die
+
+ rm -f doc/Makefile*
+ docinto doc
+ dodoc doc/* || die
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/app-i18n/anthy/files/50anthy-gentoo.el b/app-i18n/anthy/files/50anthy-gentoo.el
new file mode 100644
index 000000000000..a166df146539
--- /dev/null
+++ b/app-i18n/anthy/files/50anthy-gentoo.el
@@ -0,0 +1,5 @@
+
+;;; anthy site-lisp configuration
+
+(set-language-info "Japanese" 'input-method "japanese-anthy")
+
diff --git a/app-i18n/anthy/files/anthy-9100h-anthy_context_t.patch b/app-i18n/anthy/files/anthy-9100h-anthy_context_t.patch
new file mode 100644
index 000000000000..b46a136663bc
--- /dev/null
+++ b/app-i18n/anthy/files/anthy-9100h-anthy_context_t.patch
@@ -0,0 +1,12 @@
+diff -Naur anthy-9100h.orig/anthy/input.h anthy-9100h/anthy/input.h
+--- anthy-9100h.orig/anthy/input.h 2006-05-13 18:28:35.000000000 +0900
++++ anthy-9100h/anthy/input.h 2011-01-12 23:36:39.629749518 +0900
+@@ -10,6 +10,8 @@
+ #ifndef INPUT_H_INCLUDE
+ #define INPUT_H_INCLUDE
+
++#include "anthy.h"
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
diff --git a/app-i18n/anthy/metadata.xml b/app-i18n/anthy/metadata.xml
new file mode 100644
index 000000000000..22231128a4f7
--- /dev/null
+++ b/app-i18n/anthy/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+ <maintainer>
+ <email>hattya@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Anthy is a free and secure Japanese kana-kanji server. This ebuild includes
+ cannadic as a server-side dictionary, so you don't need any extra package to
+ run it. You can use anthy with <pkg>app-i18n/jmode</pkg> (XIM),
+ <pkg>app-i18n/uim</pkg> (XIM, GTK+ immodule) and <pkg>virtual/emacs</pkg>
+ (to enable Anthy support for emacs, build this package with emacs USE flag).
+</longdescription>
+ <use>
+ <flag name="canna-2ch">Enable support for <pkg>app-dicts/canna-2ch</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge-jp">anthy</remote-id>
+ </upstream>
+</pkgmetadata>