summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-09-17 11:16:57 +0200
committerSam James <sam@gentoo.org>2023-09-18 08:39:02 +0100
commit99358a5be7a9abcc5258226a2d2bbd2186fd69f6 (patch)
tree55f8b86a4339c94e326682939d693819ad386f9e /app-forensics
parentdev-util/pwntools: drop 4.9.0-r2 (diff)
downloadgentoo-99358a5be7a9abcc5258226a2d2bbd2186fd69f6.tar.gz
gentoo-99358a5be7a9abcc5258226a2d2bbd2186fd69f6.tar.bz2
gentoo-99358a5be7a9abcc5258226a2d2bbd2186fd69f6.zip
app-forensics/yara: add 4.4.0
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/yara/Manifest1
-rw-r--r--app-forensics/yara/yara-4.4.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/app-forensics/yara/Manifest b/app-forensics/yara/Manifest
index 35ee6f14ae87..f969268f86fc 100644
--- a/app-forensics/yara/Manifest
+++ b/app-forensics/yara/Manifest
@@ -1,2 +1,3 @@
DIST yara-4.3.1.tar.gz 2179177 BLAKE2B 071bd2201653b094f828a5ea1ca2dd08fb0e3e8ea0439784bd949fc9ebfeb3c1aa9408581c8808d2d648d988c3aaab676d61605b53446efa12d838898b7ffe16 SHA512 93a2243d54397e76175fa0106451965b7f3a1f1918307c2bae6193f3725b69f60f70c3901a12c1690368f5b37e973a65c63a299624a521d204b12b48d5efe496
DIST yara-4.3.2.tar.gz 2179265 BLAKE2B cfcc18dbd4c69f5f640ef755a8d4efe5f7ec8e313153955644fbd2adc03d1c73cddc042e95c0c0629fd58780922eb3dc1c72a5ca1bd9ff767a9e3f41f1652c98 SHA512 dc77ec46a30ca2fff33b639166fc554c9c6d9e955642774e23da3ea7dbb25fe154cfd4ef83c9808920193028b9099258a63b3f1b9a66864a1f3905f0a8e8053f
+DIST yara-4.4.0.tar.gz 2220068 BLAKE2B f9654592f3dbe493dc31bcda80c9f0e31a2a8998f47d1172afe7456a9d4ead8f475e3f0999140c952343cdeca1cedc8060a3b42c1bbe57ce617fd5b5a86dbfb3 SHA512 705db57b73e5165a26e0aaea728521f372b9f7f613665860dd22066c30e75a614815fb17ee8654780fcfc157f0137cbeda015ec088a698f31adcf071e233205f
diff --git a/app-forensics/yara/yara-4.4.0.ebuild b/app-forensics/yara/yara-4.4.0.ebuild
new file mode 100644
index 000000000000..389b8493c70f
--- /dev/null
+++ b/app-forensics/yara/yara-4.4.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A malware identification and classification tool"
+HOMEPAGE="https://virustotal.github.io/yara/"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/VirusTotal/yara.git"
+else
+ SRC_URI="https://github.com/virustotal/yara/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${PV/_/-}"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0/8"
+IUSE="+dex +dotnet +cuckoo +macho +magic profiling python test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/openssl:=
+ cuckoo? ( dev-libs/jansson:= )
+ magic? ( sys-apps/file:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+PDEPEND="python? ( =dev-python/yara-python-$(ver_cut 1)* )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable profiling) \
+ $(use_enable cuckoo) \
+ $(use_enable magic) \
+ $(use_enable dotnet) \
+ $(use_enable macho) \
+ $(use_enable dex) \
+ $(use_enable test static)
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+
+ # TODO: Allow tests to work against dyn. lib rather than building
+ # statically just for tests.
+ find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
+}