summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-06-19 19:17:05 +0200
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-06-20 23:27:34 -0700
commit157a94fb86518ba28c5185bcda744439837c6f46 (patch)
treecdba6c212873141c5b0f1ed0d08640db45e3ed62 /app-forensics/cmospwd
parentapp-forensics/cmospwd: use HTTPs (diff)
downloadgentoo-157a94fb86518ba28c5185bcda744439837c6f46.tar.gz
gentoo-157a94fb86518ba28c5185bcda744439837c6f46.tar.bz2
gentoo-157a94fb86518ba28c5185bcda744439837c6f46.zip
app-forensics/cmospwd: EAPI7 with minor changes
Closes: https://github.com/gentoo/gentoo/pull/8913
Diffstat (limited to 'app-forensics/cmospwd')
-rw-r--r--app-forensics/cmospwd/cmospwd-5.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-forensics/cmospwd/cmospwd-5.1-r1.ebuild b/app-forensics/cmospwd/cmospwd-5.1-r1.ebuild
new file mode 100644
index 000000000000..bf9611e3fd0d
--- /dev/null
+++ b/app-forensics/cmospwd/cmospwd-5.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="CmosPwd decrypts password stored in cmos used to access BIOS SETUP"
+HOMEPAGE="https://www.cgsecurity.org/wiki/CmosPwd"
+SRC_URI="https://www.cgsecurity.org/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_compile() {
+ cd src || die
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} cmospwd.c -o cmospwd || die
+}
+
+src_install() {
+ dosbin src/cmospwd
+ dodoc cmospwd.txt
+}