summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-05-21 22:11:13 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-05-21 23:30:58 -0400
commitf554c759cafd698a570f271c9bc036fcec483e9f (patch)
tree76be69ac39f3784dbb7ebeb78206a9e903c30b7c /app-emulation
parentRevert "dev-util/mingw64-toolchain: add workaround for gcc14 ICE w/ mingw" (diff)
downloadgentoo-f554c759cafd698a570f271c9bc036fcec483e9f.tar.gz
gentoo-f554c759cafd698a570f271c9bc036fcec483e9f.tar.bz2
gentoo-f554c759cafd698a570f271c9bc036fcec483e9f.zip
Revert "app-emulation/vkd3d-proton: add workaround for gcc14 ICE w/ mingw"
This reverts commit b7d87db08fa3899fd607a2f0d8137a35241b446f. Fixing in mingw64-toolchain instead, *could* keep the workaround longer for those that didn't update but likely doesn't affect many. Bug: https://bugs.gentoo.org/932319 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-2.12.ebuild3
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-2.6-r1.ebuild3
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild3
3 files changed, 0 insertions, 9 deletions
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-2.12.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-2.12.ebuild
index 718bdcf5d876..b2632b34036a 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-2.12.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-2.12.ebuild
@@ -125,9 +125,6 @@ src_configure() {
# znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
append-flags -mno-avx
- # gcc14 -fno-omit-frame-pointer ICE workaround (bug #932319)
- append-flags -fomit-frame-pointer
-
if [[ ${CHOST} != *-mingw* ]]; then
if [[ ! -v MINGW_BYPASS ]]; then
unset AR CC CXX RC STRIP WIDL
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-2.6-r1.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-2.6-r1.ebuild
index b1acedbf8fef..9a41d28143b1 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-2.6-r1.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-2.6-r1.ebuild
@@ -116,9 +116,6 @@ src_configure() {
# znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
append-flags -mno-avx
- # gcc14 -fno-omit-frame-pointer ICE workaround (bug #932319)
- append-flags -fomit-frame-pointer
-
if [[ ${CHOST} != *-mingw* ]]; then
if [[ ! -v MINGW_BYPASS ]]; then
unset AR CC CXX RC STRIP WIDL
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
index 392e5e9c4273..12ec38649be1 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
@@ -125,9 +125,6 @@ src_configure() {
# znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
append-flags -mno-avx
- # gcc14 -fno-omit-frame-pointer ICE workaround (bug #932319)
- append-flags -fomit-frame-pointer
-
if [[ ${CHOST} != *-mingw* ]]; then
if [[ ! -v MINGW_BYPASS ]]; then
unset AR CC CXX RC STRIP WIDL