summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2019-04-29 09:47:06 -0500
committerMatthias Maier <tamiko@gentoo.org>2019-04-29 09:51:49 -0500
commit691672731023785351a4f049cb749957474ecfeb (patch)
treee0d995cf583f72bd36488977d9d5714edfcc56e1 /app-emulation
parentapp-crypt/acme-tiny: PYTHON_TARGETS+="python3_7" (diff)
downloadgentoo-691672731023785351a4f049cb749957474ecfeb.tar.gz
gentoo-691672731023785351a4f049cb749957474ecfeb.tar.bz2
gentoo-691672731023785351a4f049cb749957474ecfeb.zip
app-emulation/qemu: update icon cache
Closes: https://bugs.gentoo.org/684726 Package-Manager: Portage-2.3.65, Repoman-2.3.12 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu/qemu-4.0.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-emulation/qemu/qemu-4.0.0.ebuild b/app-emulation/qemu/qemu-4.0.0.ebuild
index 9d2e78ef09c6..c3556790105d 100644
--- a/app-emulation/qemu/qemu-4.0.0.ebuild
+++ b/app-emulation/qemu/qemu-4.0.0.ebuild
@@ -11,7 +11,7 @@ PLOCALES="bg de_DE fr_FR hu it tr zh_CN"
FIRMWARE_ABI_VERSION="2.11.1-r50"
inherit eutils linux-info toolchain-funcs multilib python-r1 \
- user udev fcaps readme.gentoo-r1 pax-utils l10n
+ user udev fcaps readme.gentoo-r1 pax-utils l10n xdg-utils
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="git://git.qemu.org/qemu.git"
@@ -758,6 +758,8 @@ pkg_postinst() {
udev_reload
fi
+ xdg_icon_cache_update
+
[[ -f ${EROOT}/usr/libexec/qemu-bridge-helper ]] && \
fcaps cap_net_admin /usr/libexec/qemu-bridge-helper
@@ -797,3 +799,7 @@ pkg_info() {
fi
echo " $(best_version sys-firmware/sgabios)"
}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}