summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2017-01-19 08:08:20 -0600
committerMike Frysinger <vapier@gentoo.org>2017-01-19 08:13:37 -0600
commit68d016ae9d06dd74729c9899776cd283dcd82285 (patch)
tree085d73c7de4f5db659892900d795254192d19042 /app-emulation
parentapp-emulation/ski: fix building w/ncurses[tinfo] (diff)
downloadgentoo-68d016ae9d06dd74729c9899776cd283dcd82285.tar.gz
gentoo-68d016ae9d06dd74729c9899776cd283dcd82285.tar.bz2
gentoo-68d016ae9d06dd74729c9899776cd283dcd82285.zip
app-emulation/ski: fix missing prototype warnings
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/ski/files/ski-1.3.2-prototypes.patch31
-rw-r--r--app-emulation/ski/ski-1.3.2-r1.ebuild1
2 files changed, 32 insertions, 0 deletions
diff --git a/app-emulation/ski/files/ski-1.3.2-prototypes.patch b/app-emulation/ski/files/ski-1.3.2-prototypes.patch
new file mode 100644
index 000000000000..b66614368708
--- /dev/null
+++ b/app-emulation/ski/files/ski-1.3.2-prototypes.patch
@@ -0,0 +1,31 @@
+fix up prototypes to avoid -Wimplicit-function-declaration warnings
+
+--- a/src/coreui.h
++++ b/src/coreui.h
+@@ -177,6 +177,7 @@
+ void stepIt_setupGtk(CTR cnt);
+
+ void runIt_setupX(void);
++void runIt_setupGtk(void);
+
+
+ /*--------------------------------------------------------------------------
+--- a/src/ssGtk.c
++++ b/src/ssGtk.c
+@@ -82,6 +82,7 @@
+
+ /* externals */
+ extern dataStart;
++ADDR iAinstAddr(ADDR baseAddr, BYTE iAmode, int delta);
+
+ static GtkLabel* instcount_label;
+ /* sits in a background loop */
+@@ -100,7 +101,7 @@
+ }
+
+
+-void runIt_setupGtk(void *data)
++void runIt_setupGtk(void)
+ {
+ g_idle_add(runItGtk, NULL);
+ stopPressed = NO;
diff --git a/app-emulation/ski/ski-1.3.2-r1.ebuild b/app-emulation/ski/ski-1.3.2-r1.ebuild
index 23d9c253841c..3ca262479f5d 100644
--- a/app-emulation/ski/ski-1.3.2-r1.ebuild
+++ b/app-emulation/ski/ski-1.3.2-r1.ebuild
@@ -37,6 +37,7 @@ PATCHES=(
"${FILESDIR}"/${P}-binutils.patch
"${FILESDIR}"/${P}-uselib.patch #592226
"${FILESDIR}"/${P}-ncurses-config.patch
+ "${FILESDIR}"/${P}-prototypes.patch
)
src_prepare() {