summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2024-04-05 15:14:19 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2024-04-06 12:03:02 +0200
commit54c98c28db0e46b9e9f78ef2547cceeca8ecfab2 (patch)
tree60e0f38e9d33592a954729d396262dbe7a77b571 /app-emulation
parentapp-emulation/free42: drop 3.0.21, 3.1.2 (diff)
downloadgentoo-54c98c28db0e46b9e9f78ef2547cceeca8ecfab2.tar.gz
gentoo-54c98c28db0e46b9e9f78ef2547cceeca8ecfab2.tar.bz2
gentoo-54c98c28db0e46b9e9f78ef2547cceeca8ecfab2.zip
app-emulation/plus42: add 1.1.9
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/plus42/Manifest1
-rw-r--r--app-emulation/plus42/plus42-1.1.9.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-emulation/plus42/Manifest b/app-emulation/plus42/Manifest
index 7e72fa0d47be..33a564084cbf 100644
--- a/app-emulation/plus42/Manifest
+++ b/app-emulation/plus42/Manifest
@@ -1,3 +1,4 @@
DIST plus42-upstream-1.0.21.tgz 7596740 BLAKE2B 2710ec70682ea8a68ff07388c210bd253f5a91736caa017efed036b0cba41a9895721287246982477adaf4288d79d195cf6543b79d5e0905b62acc91becd4da8 SHA512 55b42e006ce003c9e619fa10ec7e28319f82444bce0f811f9ebdd16c0ceeded9e978a3f7c0b134bdc17c39a55f1071b8245d099d1c7d9a7b81bfe850d30bd962
DIST plus42-upstream-1.1.2.tgz 7607688 BLAKE2B 3d353898cf9ad51388ab40d86265dc83822f6ac658ca8c8c1a2c0ce8b7801b64c2d454d129743049c46723caf5b82f90e5939b3e1e08431a8246472256033c5e SHA512 7418dce2d31deb3b4d5275921bfd84eafd15546c0a3f0110c463ec620e8b53c99c6ce74401aafa89e7658843711ef5b02ca144edafbcd8b4aad4a26f93ba9d70
DIST plus42-upstream-1.1.3.tgz 7610112 BLAKE2B 6c55a8c2acebbc0e442308e0f078d2ac86f9866d9dbe808a17007a3c3729114f24379401267787107d11e4f3559e14c86f39051da3a956928a7c4c97c1867c31 SHA512 05fd0fb3f330ad0842d28df46ec89d3347cbfca776c6e73092261a96f860677d8f9a6de96ee98adfed4abe5d950a45cec6e6056bb97dd471204d644cbdb82d10
+DIST plus42-upstream-1.1.9.tgz 7612675 BLAKE2B d6b05221b11705c553be2cabe8adc81b892861b86aeb3b234e7fef44bb79551b74f94caaa563f3fa55bc62f988545493d118bab488818cc835ccbfd309c95874 SHA512 bbfd519006c3f24de469a0c928271edb9a2ee92c32bf1eccb313fffb4e13e461875f608561149b8d8de57565cb835c407c7ee2bcf959b198a728669160ff85f6
diff --git a/app-emulation/plus42/plus42-1.1.9.ebuild b/app-emulation/plus42/plus42-1.1.9.ebuild
new file mode 100644
index 000000000000..3916a804001b
--- /dev/null
+++ b/app-emulation/plus42/plus42-1.1.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PV="${PN}-upstream-${PV}"
+
+DESCRIPTION="An Enhanced HP-42S Calculator Simulator"
+HOMEPAGE="https://thomasokken.com/plus42/"
+SRC_URI="https://thomasokken.com/plus42/upstream/${MY_PV}.tgz"
+S=${WORKDIR}/${MY_PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa"
+
+DEPEND="app-accessibility/at-spi2-core
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ alsa? ( media-libs/alsa-lib )"
+RDEPEND="${DEPEND}"
+
+DOCS=( CREDITS HISTORY README )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.9-fix-makefile.patch"
+ "${FILESDIR}/${PN}-1.0.12-fix-build-intel-lib.patch"
+)
+
+src_prepare() {
+ default
+}
+
+src_compile() {
+ local myconf
+ use alsa && myconf="AUDIO_ALSA=yes"
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" ${myconf} -C gtk
+ emake -C gtk clean
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" BCD_MATH=1 ${myconf} -C gtk
+}
+
+src_install() {
+ default
+ dobin gtk/plus42bin gtk/plus42dec
+}