summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-01-13 07:26:04 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-01-13 08:10:22 -0500
commit2c17819192fa039c17d96ab87d86ce275161f25e (patch)
treed4d4dd8d5af75352de9e43e4abfad721194ac7ae /app-emulation/wine-proton
parentapp-emulation/wine-proton: adjust style (diff)
downloadgentoo-2c17819192fa039c17d96ab87d86ce275161f25e.tar.gz
gentoo-2c17819192fa039c17d96ab87d86ce275161f25e.tar.bz2
gentoo-2c17819192fa039c17d96ab87d86ce275161f25e.zip
app-emulation/wine-proton: make libdrm[video_cards_amdgpu] optional in live
Had forgotten about it but wine offers generic switches for all dlls, so can use that rather than modify sources. The dll being entirely missing hopefully has no negative impact (should gracefully just not use it even for amdgpu). Imagine may be new releases soon'ish (or proton 9), and meant to adjust this before then as it'll be annoying for non-amdgpu users to enable it on libdrm. May possibly need masking on x86 (32bit), have not tested if it builds anyway. Albeit doubt this is usable there regardless. Generally unsure if the proton variant should even keep x86 keywords though (was kind of flaky when I tested it for x86 while considering stable and not entirely sure it works on a real system). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/wine-proton')
-rw-r--r--app-emulation/wine-proton/wine-proton-8.0.9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/app-emulation/wine-proton/wine-proton-8.0.9999.ebuild b/app-emulation/wine-proton/wine-proton-8.0.9999.ebuild
index ed67e6b6fe21..e6660a9082bf 100644
--- a/app-emulation/wine-proton/wine-proton-8.0.9999.ebuild
+++ b/app-emulation/wine-proton/wine-proton-8.0.9999.ebuild
@@ -31,7 +31,7 @@ IUSE="
+abi_x86_32 +abi_x86_64 +alsa crossdev-mingw custom-cflags
+fontconfig +gecko +gstreamer llvm-libunwind +mono nls osmesa
perl pulseaudio +sdl selinux +ssl +strip udev udisks +unwind
- usb v4l +xcomposite xinerama
+ usb v4l video_cards_amdgpu +xcomposite xinerama
"
# tests are non-trivial to run, can hang easily, don't play well with
@@ -68,7 +68,7 @@ WINE_COMMON_DEPEND="
sys-devel/gcc:*
x11-libs/libX11[${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
- x11-libs/libdrm[video_cards_amdgpu,${MULTILIB_USEDEP}]
+ x11-libs/libdrm[video_cards_amdgpu?,${MULTILIB_USEDEP}]
alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )
gstreamer? (
dev-libs/glib:2[${MULTILIB_USEDEP}]
@@ -221,6 +221,7 @@ src_configure() {
$(use_enable gecko mshtml)
$(use_enable mono mscoree)
+ $(use_enable video_cards_amdgpu amd_ags_x64)
--disable-tests
$(use_with alsa)
$(use_with fontconfig)