summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-10-16 12:18:24 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-10-16 12:22:03 +0200
commitdbcb9791e1814ff54c3bcc076aa1952fb10dba1d (patch)
tree0213a237bb2b2c59c40544acdf12a80b4cc29ef8 /app-emulation/virtualbox-modules
parentapp-metrics/pushgateway: Remove old (diff)
downloadgentoo-dbcb9791e1814ff54c3bcc076aa1952fb10dba1d.tar.gz
gentoo-dbcb9791e1814ff54c3bcc076aa1952fb10dba1d.tar.bz2
gentoo-dbcb9791e1814ff54c3bcc076aa1952fb10dba1d.zip
virtualbox packages: Bump to versions 5.2.34 and 6.0.14
Bug: https://bugs.gentoo.org/697492 Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-emulation/virtualbox-modules')
-rw-r--r--app-emulation/virtualbox-modules/Manifest2
-rw-r--r--app-emulation/virtualbox-modules/virtualbox-modules-5.2.34.ebuild51
-rw-r--r--app-emulation/virtualbox-modules/virtualbox-modules-6.0.14.ebuild52
3 files changed, 105 insertions, 0 deletions
diff --git a/app-emulation/virtualbox-modules/Manifest b/app-emulation/virtualbox-modules/Manifest
index b0e32b7adcfe..93960c82fae0 100644
--- a/app-emulation/virtualbox-modules/Manifest
+++ b/app-emulation/virtualbox-modules/Manifest
@@ -1,4 +1,6 @@
DIST vbox-kernel-module-src-5.2.26.tar.xz 642096 BLAKE2B fa908b8dda4c49e880005f22d4ec159ba4e84b20d3cf8f514ec5ad0ea556499b0df25fb714bb5f9a3474e6fc1cba67f6d56fddaee748b9561bbe31a003dd0657 SHA512 7f37be1b35772d59cd3df9b61dec436450de3c038faf2cd22fb891fee7270aa7f87f146f72497ffeb63dfe869cccd3f2788562d23fc51afd83ca19159f2a6810
DIST vbox-kernel-module-src-5.2.32.tar.xz 642428 BLAKE2B 0dda5cb5608c1eed22bea209564d53c5f7eab58ca620db2cc441e3c1ba9ad66609c4ef13df07fd29b691f2941a070f9852e8729cd386081df6a82ede345f33c5 SHA512 fadedab690cb7dee8b9a6747ed711d924bf3bce8999b24e7b64cb8738c53c2fa7372b1a8e8535e7e4ef0235aec02d4a3f1f67cd07d7621934fab684c5163329e
+DIST vbox-kernel-module-src-5.2.34.tar.xz 642756 BLAKE2B 8a1dacc71b0c033130db84f46ab6029839e4c95cd20b6c982716fde9a83070f4597a9418ef2747c5b5714eafd5c1453c67eb1477104cd1185baf408301bc0226 SHA512 2feefa7867c664f1a1af04181e6db4cf2ab18e8a42dc57afe5fe13d35de889c2a88b79eb43642e024d99decfdd79c42891989158016edb09d5001783c4cb7ac3
DIST vbox-kernel-module-src-6.0.10.tar.xz 669008 BLAKE2B 80250aeca8421aa0b88efb1d090f78d0bc6c7b4b2c3b7e0c5c7953d9ef5246ee25df6fa14b75b821e1e3d05cda3ff975560ede89dc482e34faa801a592405a9f SHA512 afab0130c14b86e822f2a9528373388a9eeee952deec9ff7158e4b788b64343235f3a3da10218bfabcb71dd4d89c8ace0031ea9b64d7385140f6c580b5087333
DIST vbox-kernel-module-src-6.0.12.tar.xz 669148 BLAKE2B 2291e3fcb9f049ce5657288151d182dfc9a3d6d6e8e1b32047e4b682f35e56f0a5bb5d3ad7efbc98082d2d1823aeb821099e9878b8a237322e8900fb2e2d65de SHA512 e9d8fcbfc076bf4e7d4dc5954e0c24509273c6358ee2de9ddfa87ea650b69fdc31d223595d610c1dd921efd6620ba5285f7f6a10170e90e706bf731e3629dc51
+DIST vbox-kernel-module-src-6.0.14.tar.xz 669396 BLAKE2B e2dc77f33176af16be0fcad8851dd42eb2b7b21da35dc434951e3300e45fec4b516741f6122ae43aed2ee332323221098f047b5206ca63eb7741925a40682728 SHA512 1bcc78dff3305bb7186cec2a844188411a62fe32d0581c4de21843ee513925d5dfc9bd4dedb3cc90f0e1c165c7ae6d856590cc359e36cc8605b164c2c9979380
diff --git a/app-emulation/virtualbox-modules/virtualbox-modules-5.2.34.ebuild b/app-emulation/virtualbox-modules/virtualbox-modules-5.2.34.ebuild
new file mode 100644
index 000000000000..c4b01a1b3f96
--- /dev/null
+++ b/app-emulation/virtualbox-modules/virtualbox-modules-5.2.34.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# XXX: the tarball here is just the kernel modules split out of the binary
+# package that comes from virtualbox-bin
+
+EAPI=7
+
+inherit linux-mod user
+
+MY_P="vbox-kernel-module-src-${PV}"
+DESCRIPTION="Kernel Modules for Virtualbox"
+HOMEPAGE="https://www.virtualbox.org/"
+SRC_URI="https://dev.gentoo.org/~polynomial-c/virtualbox/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pax_kernel"
+
+RDEPEND="!=app-emulation/virtualbox-9999"
+
+S="${WORKDIR}"
+
+BUILD_TARGETS="all"
+BUILD_TARGET_ARCH="${ARCH}"
+MODULE_NAMES="vboxdrv(misc:${S}) vboxnetflt(misc:${S}) vboxnetadp(misc:${S}) vboxpci(misc:${S})"
+
+pkg_setup() {
+ enewgroup vboxusers
+ linux-mod_pkg_setup
+ BUILD_PARAMS="CC=$(tc-getBUILD_CC) KERN_DIR=${KV_DIR} KERN_VER=${KV_FULL} O=${KV_OUT_DIR} V=1 KBUILD_VERBOSE=1"
+}
+
+src_prepare() {
+ if use pax_kernel && kernel_is -ge 3 0 0 ; then
+ eapply -p0 "${FILESDIR}"/${PN}-5.2.8-pax-const.patch
+ fi
+
+ default
+}
+
+src_install() {
+ linux-mod_src_install
+ insinto /usr/lib/modules-load.d/
+ doins "${FILESDIR}"/virtualbox.conf
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+}
diff --git a/app-emulation/virtualbox-modules/virtualbox-modules-6.0.14.ebuild b/app-emulation/virtualbox-modules/virtualbox-modules-6.0.14.ebuild
new file mode 100644
index 000000000000..7257cb3b5812
--- /dev/null
+++ b/app-emulation/virtualbox-modules/virtualbox-modules-6.0.14.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# XXX: the tarball here is just the kernel modules split out of the binary
+# package that comes from virtualbox-bin
+
+EAPI=7
+
+inherit linux-mod user
+
+MY_P="vbox-kernel-module-src-${PV}"
+DESCRIPTION="Kernel Modules for Virtualbox"
+HOMEPAGE="https://www.virtualbox.org/"
+SRC_URI="https://dev.gentoo.org/~polynomial-c/virtualbox/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+[[ "${PV}" == *_beta* ]] || [[ "${PV}" == *_rc* ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE="pax_kernel"
+
+RDEPEND="!=app-emulation/virtualbox-9999"
+
+S="${WORKDIR}"
+
+BUILD_TARGETS="all"
+BUILD_TARGET_ARCH="${ARCH}"
+MODULE_NAMES="vboxdrv(misc:${S}) vboxnetflt(misc:${S}) vboxnetadp(misc:${S}) vboxpci(misc:${S})"
+
+pkg_setup() {
+ enewgroup vboxusers
+ linux-mod_pkg_setup
+ BUILD_PARAMS="CC=$(tc-getBUILD_CC) KERN_DIR=${KV_DIR} KERN_VER=${KV_FULL} O=${KV_OUT_DIR} V=1 KBUILD_VERBOSE=1"
+}
+
+src_prepare() {
+ if use pax_kernel && kernel_is -ge 3 0 0 ; then
+ eapply -p0 "${FILESDIR}"/${PN}-5.2.8-pax-const.patch
+ fi
+
+ default
+}
+
+src_install() {
+ linux-mod_src_install
+ insinto /usr/lib/modules-load.d/
+ doins "${FILESDIR}"/virtualbox.conf
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+}